summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/meshlab/files/2016.12/meshlab-2016.12-qt-5.15.patch33
-rw-r--r--media-gfx/meshlab/meshlab-2016.12-r4.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/meshlab/files/2016.12/meshlab-2016.12-qt-5.15.patch b/media-gfx/meshlab/files/2016.12/meshlab-2016.12-qt-5.15.patch
new file mode 100644
index 000000000000..ab052cd69eb9
--- /dev/null
+++ b/media-gfx/meshlab/files/2016.12/meshlab-2016.12-qt-5.15.patch
@@ -0,0 +1,33 @@
+From c57222e79f1c7840e1ed01a4abd17d089f5e5185 Mon Sep 17 00:00:00 2001
+From: alemuntoni <muntoni.alessandro@gmail.com>
+Date: Tue, 26 May 2020 12:35:03 +0200
+Subject: [PATCH] missing include
+
+---
+ meshlab/glarea.cpp | 1 +
+ meshlab/meshlab.pro | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/meshlab/glarea.cpp b/meshlab/glarea.cpp
+index 6c0421062..dfd7af229 100644
+--- a/meshlab/glarea.cpp
++++ b/meshlab/glarea.cpp
+@@ -34,6 +34,7 @@
+ #include <QFileDialog>
+ #include <QClipboard>
+ #include <QLocale>
++#include <QPainterPath>
+
+ #include <wrap/gl/picking.h>
+ #include <wrap/qt/trackball.h>
+diff --git a/meshlab/meshlab.pro b/meshlab/meshlab.pro
+index 26ef88d00..842eb5ea5 100644
+--- a/meshlab/meshlab.pro
++++ b/meshlab/meshlab.pro
+@@ -1,5 +1,6 @@
+ # You have to copy the file by hand into the meshlab.app/Contents/Resources directory.
+ # ICON += images/meshlab_obj.icns
++QT += gui
+ QT += opengl
+ QT += xml
+ QT += xmlpatterns
diff --git a/media-gfx/meshlab/meshlab-2016.12-r4.ebuild b/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
index 35b63858d6b5..505a20ab0b58 100644
--- a/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
+++ b/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
@@ -62,6 +62,7 @@ PATCHES=(
"${FILESDIR}/${PV}/${P}-asString.patch"
"${FILESDIR}/${PV}/${P}-qprintable.patch"
"${FILESDIR}/${PV}/${P}-qt-includes.patch"
+ "${FILESDIR}/${PV}/${P}-qt-5.15.patch"
)
src_prepare() {