summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/clang-runtime/clang-runtime-4.0.0_rc1-r1.ebuild (renamed from sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild)6
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild7
2 files changed, 7 insertions, 6 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1-r1.ebuild
index 5acf530ff212..5b6baf94371c 100644
--- a/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1-r1.ebuild
@@ -11,14 +11,14 @@ HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
LICENSE="metapackage"
-SLOT="0"
+SLOT="${PV%_*}"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+compiler-rt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
- ~sys-libs/compiler-rt-${PV}
- sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV} )
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
index dd325de97a95..b23e4e08527b 100644
--- a/sys-devel/clang-runtime/clang-runtime-9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -11,14 +11,15 @@ HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
LICENSE="metapackage"
-SLOT="0"
+# Note: keep it matching clang-9999 version
+SLOT="5.0.0"
KEYWORDS=""
IUSE="+compiler-rt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
- ~sys-libs/compiler-rt-${PV}
- sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV} )
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"