summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/shadowsocks-libev/files/shadowsocks-libev-3.3.4-gcc10.patch24
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.4.ebuild3
2 files changed, 27 insertions, 0 deletions
diff --git a/net-proxy/shadowsocks-libev/files/shadowsocks-libev-3.3.4-gcc10.patch b/net-proxy/shadowsocks-libev/files/shadowsocks-libev-3.3.4-gcc10.patch
new file mode 100644
index 000000000000..7a480f12b240
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/files/shadowsocks-libev-3.3.4-gcc10.patch
@@ -0,0 +1,24 @@
+diff --git a/src/http.h b/src/http.h
+index 914815a..e312dd3 100644
+--- a/src/http.h
++++ b/src/http.h
+@@ -29,6 +29,6 @@
+ #include <stdio.h>
+ #include "protocol.h"
+
+-const protocol_t *const http_protocol;
++extern const protocol_t *const http_protocol;
+
+ #endif
+diff --git a/src/tls.h b/src/tls.h
+index 3998913..ddbee11 100644
+--- a/src/tls.h
++++ b/src/tls.h
+@@ -28,6 +28,6 @@
+
+ #include "protocol.h"
+
+-const protocol_t *const tls_protocol;
++extern const protocol_t *const tls_protocol;
+
+ #endif
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.4.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.4.ebuild
index be40495a1c07..353791fc2639 100644
--- a/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.4.ebuild
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.4.ebuild
@@ -36,6 +36,9 @@ DEPEND="${RDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-gcc10.patch"
+)
src_prepare() {
sed -i 's|AC_CONFIG_FILES(\[libbloom/Makefile libcork/Makefile libipset/Makefile\])||' \
configure.ac || die