summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch43
-rw-r--r--media-libs/fontconfig/fontconfig-2.13.1-r2.ebuild (renamed from media-libs/fontconfig/fontconfig-2.13.1-r1.ebuild)1
2 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/fontconfig/files/fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch b/media-libs/fontconfig/files/fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch
new file mode 100644
index 000000000000..cd66082eedd8
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch
@@ -0,0 +1,43 @@
+https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107
+
+Reversion of part of:
+https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/f5dd8512bdf9fd8e01c30ae36f593758b29385cf
+
+--- /src/fcdir.c
++++ /src/fcdir.c
+@@ -421,13 +421,6 @@
+ /* Not using existing cache file, construct new cache */
+ if (!cache)
+ cache = FcDirCacheScan (dir, config);
+- if (cache)
+- {
+- FcFontSet *fs = FcCacheSet (cache);
+-
+- if (cache->dirs_count == 0 && (!fs || fs->nfont == 0))
+- FcDirCacheDeleteUUID (dir, config);
+- }
+
+ return cache;
+ }
+--- /test/run-test.sh
++++ /test/run-test.sh
+@@ -239,19 +239,4 @@
+
+ rm -rf $MyPWD/sysroot
+
+-dotest "deleting .uuid file on empty dir"
+-prep
+-cp $FONT1 $FONT2 $FONTDIR
+-$FCCACHE $FONTDIR
+-sleep 1
+-rm -f $FONTDIR/*pcf
+-$FCCACHE $FONTDIR
+-rmdir $FONTDIR > /dev/null 2>&1
+-if [ $? != 0 ]; then
+- echo "*** Test failed: $TEST"
+- echo "$FONTDIR isn't empty"
+- ls -al $FONTDIR
+- exit 1
+-fi
+-
+ rm -rf $FONTDIR $CACHEFILE $CACHEDIR $FONTCONFIG_FILE out
diff --git a/media-libs/fontconfig/fontconfig-2.13.1-r1.ebuild b/media-libs/fontconfig/fontconfig-2.13.1-r2.ebuild
index fdc25117f943..0ba7f651fabb 100644
--- a/media-libs/fontconfig/fontconfig-2.13.1-r1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.13.1-r2.ebuild
@@ -36,6 +36,7 @@ PDEPEND="!x86-winnt? ( app-eselect/eselect-fontconfig )
PATCHES=(
"${FILESDIR}"/${PN}-2.10.2-docbook.patch # 310157
"${FILESDIR}"/${PN}-2.12.3-latin-update.patch # 130466 + make liberation default
+ "${FILESDIR}"/${P}-revert_delete_.uuid_for_empty_directory.patch # 666418
# Patches from upstream (can usually be removed with next version bump)
"${FILESDIR}"/${P}-static_build.patch