summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/qstylizer/Manifest1
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index 690b5c56dd46..6d47d0013c65 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1 +1,2 @@
DIST qstylizer-0.2.3.gh.tar.gz 20813 BLAKE2B edb19f9bcadee3229a1d98cc7170ba7bbab266fea74ab42987380dd8aec0ba4d02dda0fb7522f2cfbc52feb5646e44ee1603528d3331315ddcbcc18095a9ca76 SHA512 ba5188f702d4fbd43d963be206c75d55710bfe63accc84aea3bfd03ad06a0cb484d50b538c2d1d6a7ce21055d0b2eefb2cb35a732b929f5477033a8ddea945c0
+DIST qstylizer-0.2.4.gh.tar.gz 20822 BLAKE2B 6ecb70d2d9c602fdd13b2927cffde40e555e9bb6fa9855cc79b395eb4783452128ad4a6c7a428b13e8050b3df8c1bd393c649d42553058b7ef6653f1ac8f1cd8 SHA512 e55d9486f5cb15c0365fa17cded858b71b0fe33e6df777e12800f0a360e7cffade55c0f88089a20e76cb5b3d2fc8cdfd0d514466b7840c20c397a236657ad665
diff --git a/dev-python/qstylizer/qstylizer-0.2.4.ebuild b/dev-python/qstylizer/qstylizer-0.2.4.ebuild
new file mode 100644
index 000000000000..a73a48d3b655
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.2.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="
+ https://github.com/blambright/qstylizer/
+ https://pypi.org/project/qstylizer/
+"
+SRC_URI="
+ https://github.com/blambright/qstylizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ <dev-python/tinycss2-2[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-autoprogram
+
+export PBR_VERSION=${PV}