summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libsmi/libsmi-0.5.0-r5.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-libs/libsmi/libsmi-0.5.0-r5.ebuild b/net-libs/libsmi/libsmi-0.5.0-r5.ebuild
index 8ad62583bc6f..ceb218402dd4 100644
--- a/net-libs/libsmi/libsmi-0.5.0-r5.ebuild
+++ b/net-libs/libsmi/libsmi-0.5.0-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A Library to Access SMI MIB Information"
HOMEPAGE="https://www.ibr.cs.tu-bs.de/projects/libsmi/ https://gitlab.ibr.cs.tu-bs.de/nm/libsmi"
@@ -31,6 +31,13 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # bug #944131
+ append-cflags -std=gnu17
+
+ econf
+}
+
src_test() {
# sming test is known to fail and some other fail if LC_ALL!=C:
# https://mail.ibr.cs.tu-bs.de/pipermail/libsmi/2008-March/001014.html