summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/store/Manifest1
-rw-r--r--dev-haskell/store/store-0.3.1.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-haskell/store/Manifest b/dev-haskell/store/Manifest
index d7365f49f653..420b09187930 100644
--- a/dev-haskell/store/Manifest
+++ b/dev-haskell/store/Manifest
@@ -1,2 +1 @@
-DIST store-0.3.1.tar.gz 41555 BLAKE2B 6dc4cc284725db02987755ccd7665f241cc24b50449707d7af59ecbc82617bfc3445d9be57c37036f6bffb90870cf326d1519f131163c7dc7a87589fbc5718a1 SHA512 7e6064cbee01ce7357e5b7235d502ee9b5b323358ebd7e71b5b310830ae52595384bb143dbbbad8e28cdde2c9001f1ae9ea03b47f2dc5cf50ac18cb2c4e9d7cd
DIST store-0.7.5.tar.gz 43180 BLAKE2B 990907bb8135f82a6ee4bf7b4e0389ef036e9c5334d3c26606723788ee04d35d86ff1d7ab1b2d8a48c61b299933f5c285d8846e79806196b68b99a9b6b7e0200 SHA512 14b8e36cfc04eec80a6a37d27dbac08887a3bebd226941f368076ea39b09a5c432c4d38ce860776a677b8829ecbabd3f2448cc2437e00ebcf2fb3a36d1715af0
diff --git a/dev-haskell/store/store-0.3.1.ebuild b/dev-haskell/store/store-0.3.1.ebuild
deleted file mode 100644
index e1de2e33e1c3..000000000000
--- a/dev-haskell/store/store-0.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.1.9999
-#hackport: flags: -small-bench,-comparison-bench
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast binary serialization"
-HOMEPAGE="https://github.com/fpco/store#readme"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/async-2.0.2:=[profile?]
- >=dev-haskell/base-orphans-0.4.3:=[profile?]
- >=dev-haskell/base64-bytestring-0.1.1:=[profile?]
- >=dev-haskell/conduit-1.2.3.1:=[profile?]
- >=dev-haskell/contravariant-1.3:=[profile?]
- >=dev-haskell/cryptohash-0.11.6:=[profile?]
- >=dev-haskell/free-4.11:=[profile?]
- >=dev-haskell/hashable-1.2.3.1:=[profile?]
- >=dev-haskell/hspec-2.1.2:=[profile?]
- >=dev-haskell/hspec-smallcheck-0.3.0:=[profile?]
- >=dev-haskell/lifted-base-0.2.3.3:=[profile?]
- >=dev-haskell/monad-control-0.3.3.0:=[profile?]
- >=dev-haskell/mono-traversable-0.7.0:=[profile?]
- >=dev-haskell/network-2.6.0.2:=[profile?]
- >=dev-haskell/primitive-0.6:=[profile?]
- >=dev-haskell/resourcet-1.1.3.3:=[profile?]
- >=dev-haskell/safe-0.3.8:=[profile?]
- >=dev-haskell/semigroups-0.8:=[profile?]
- >=dev-haskell/smallcheck-1.1.1:=[profile?]
- >=dev-haskell/store-core-0.3:=[profile?] <dev-haskell/store-core-0.4:=[profile?]
- >=dev-haskell/streaming-commons-0.1.10.0:=[profile?]
- >=dev-haskell/syb-0.4.4:=[profile?]
- >=dev-haskell/text-1.2.0.4:=[profile?]
- >=dev-haskell/th-lift-0.7.1:=[profile?]
- >=dev-haskell/th-lift-instances-0.1.4:=[profile?]
- >=dev-haskell/th-orphans-0.12.2:=[profile?]
- >=dev-haskell/th-reify-many-0.1.6:=[profile?]
- >=dev-haskell/th-utilities-0.2:=[profile?]
- >=dev-haskell/unordered-containers-0.2.5.1:=[profile?]
- >=dev-haskell/vector-0.10.12.3:=[profile?]
- >=dev-haskell/void-0.5.11:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( dev-haskell/cereal
- dev-haskell/cereal-vector
- dev-haskell/criterion
- dev-haskell/vector-binary-instances
- dev-haskell/weigh )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-comparison-bench \
- --flag=-small-bench
-}