summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/handbrake/handbrake-1.4.2.ebuild4
-rw-r--r--media-video/handbrake/handbrake-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/media-video/handbrake/handbrake-1.4.2.ebuild b/media-video/handbrake/handbrake-1.4.2.ebuild
index cc2edcd67ff8..74fc7df0d86c 100644
--- a/media-video/handbrake/handbrake-1.4.2.ebuild
+++ b/media-video/handbrake/handbrake-1.4.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools python-any-r1 xdg
+inherit autotools python-any-r1 toolchain-funcs xdg
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/HandBrake/HandBrake.git"
@@ -110,6 +110,8 @@ src_prepare() {
}
src_configure() {
+ tc-export AR RANLIB STRIP
+
# Libav was replaced in 1.2 with ffmpeg by default
# but I've elected to not make people change their use flags for AAC
# as its the same code anyway
diff --git a/media-video/handbrake/handbrake-9999.ebuild b/media-video/handbrake/handbrake-9999.ebuild
index cc2edcd67ff8..74fc7df0d86c 100644
--- a/media-video/handbrake/handbrake-9999.ebuild
+++ b/media-video/handbrake/handbrake-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools python-any-r1 xdg
+inherit autotools python-any-r1 toolchain-funcs xdg
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/HandBrake/HandBrake.git"
@@ -110,6 +110,8 @@ src_prepare() {
}
src_configure() {
+ tc-export AR RANLIB STRIP
+
# Libav was replaced in 1.2 with ffmpeg by default
# but I've elected to not make people change their use flags for AAC
# as its the same code anyway