summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libezV24/files/libezV24-0.1.1-test.patch4
-rw-r--r--dev-libs/libezV24/libezV24-0.1.1-r1.ebuild34
-rw-r--r--dev-libs/libezV24/libezV24-0.1.1.ebuild4
3 files changed, 38 insertions, 4 deletions
diff --git a/dev-libs/libezV24/files/libezV24-0.1.1-test.patch b/dev-libs/libezV24/files/libezV24-0.1.1-test.patch
index f3c2b676546f..425c32036560 100644
--- a/dev-libs/libezV24/files/libezV24-0.1.1-test.patch
+++ b/dev-libs/libezV24/files/libezV24-0.1.1-test.patch
@@ -4,8 +4,8 @@ RCS file: /cvsroot/ezv24/libezv24/test-v24.c,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -p -r1.2 -r1.3
---- test-v24.c 11 Feb 2003 13:29:43 -0000 1.2
-+++ test-v24.c 13 Oct 2003 07:50:26 -0000 1.3
+--- a/test-v24.c 11 Feb 2003 13:29:43 -0000 1.2
++++ b/test-v24.c 13 Oct 2003 07:50:26 -0000 1.3
@@ -30,7 +33,11 @@
#include <string.h>
#include <signal.h>
diff --git a/dev-libs/libezV24/libezV24-0.1.1-r1.ebuild b/dev-libs/libezV24/libezV24-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..b6b2424b2a9a
--- /dev/null
+++ b/dev-libs/libezV24/libezV24-0.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library that provides an easy API to Linux serial ports"
+HOMEPAGE="http://ezv24.sourceforge.net"
+SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+HTML_DOCS=( api-html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-test.patch
+)
+
+src_prepare() {
+ tc-export AR CC RANLIB
+ default
+ sed -i -e 's:__LINUX__:__linux__:' *.c *.h || die
+}
+
+src_install() {
+ export NO_LDCONFIG="stupid"
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ einstalldocs
+}
diff --git a/dev-libs/libezV24/libezV24-0.1.1.ebuild b/dev-libs/libezV24/libezV24-0.1.1.ebuild
index db6b724d1f4c..30ac27fe8784 100644
--- a/dev-libs/libezV24/libezV24-0.1.1.ebuild
+++ b/dev-libs/libezV24/libezV24-0.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
@@ -9,7 +9,7 @@ DESCRIPTION="library that provides an easy API to Linux serial ports"
HOMEPAGE="http://ezv24.sourceforge.net"
SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 ppc sparc x86"
IUSE=""