summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nbxmpp/Manifest1
-rw-r--r--dev-python/nbxmpp/nbxmpp-5.0.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index f2a0b2589cb9..13343f181b0b 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,2 +1,3 @@
DIST python-nbxmpp-4.5.4.tar.bz2 138170 BLAKE2B 00a4919032dd29828dc735695afe9c0814a8fe2ec765a534257768896d9f27bc3a395275d546ad717bdd16c97161e8f0a8acaf43cdb7bd9404e40bc72f2c3da5 SHA512 fcaedae519d8cd2d52cc65721ab1e743569ba1cf7c29f2db41ed5671ba0f2c5b47f1f6d9521e1614e89e21512a4575c6788316cdb86936f0c4886d54c3831bb3
DIST python-nbxmpp-5.0.1.tar.bz2 142702 BLAKE2B 5459da538e3c05959c382e70fe8348b566333f4f68e76775b7bc8760f294ecc3bdb999124d1124bd5d7874af209f699eb4ffa1a15ce61ad70f98f235c70e98dd SHA512 eb20df090ec61013e6f26288798aeb2f2d61eab493cb4a52d5097a85d6dab8c45f033f2064583af5bf3ed920be33107419a958b65df2cf13fcd8ea6ae3297adf
+DIST python-nbxmpp-5.0.2.tar.bz2 142857 BLAKE2B 555370478aaafb24449b6147b4a80de5e300d1df83fe9e6fba87fa9e29eb09d51b16d74df63dbe6dd2c806a31bbd83e41eaf1a5261ba9b69996c10455bfbbcf8 SHA512 947fb4b47f98196becb0065898b51e7dcb6e3fbbc97cacd89641e4a57c5f310c9825029f5f54135f33d3e58b089d1063bf1e3d3af3cdc3ebf7dd9490d0277c92
diff --git a/dev-python/nbxmpp/nbxmpp-5.0.2.ebuild b/dev-python/nbxmpp/nbxmpp-5.0.2.ebuild
new file mode 100644
index 000000000000..0299ed984918
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-5.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest