summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/garden/files/garden-1.0.9-gcc52.patch20
-rw-r--r--games-action/garden/garden-1.0.9.ebuild3
2 files changed, 22 insertions, 1 deletions
diff --git a/games-action/garden/files/garden-1.0.9-gcc52.patch b/games-action/garden/files/garden-1.0.9-gcc52.patch
new file mode 100644
index 000000000000..60f927217c6e
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-gcc52.patch
@@ -0,0 +1,20 @@
+--- src/stuff.c.old 2015-09-22 08:57:21.482794770 +0200
++++ src/stuff.c 2015-09-22 08:58:22.567815095 +0200
+@@ -52,7 +52,7 @@
+ float cos_table[ANGLE_1];
+ float sin_table[ANGLE_1];
+
+-inline int xpart (int angle, int length);
++extern inline int xpart (int angle, int length);
+
+ void init_trig (void)
+ {
+@@ -72,7 +72,7 @@
+ return (cos_table[angle & 1023] * length);
+ }
+
+-inline int ypart (int angle, int length)
++extern inline int ypart (int angle, int length)
+ {
+ return (sin_table[angle & 1023] * length);
+ }
diff --git a/games-action/garden/garden-1.0.9.ebuild b/games-action/garden/garden-1.0.9.ebuild
index 62df12c7f80a..63eb620271a3 100644
--- a/games-action/garden/garden-1.0.9.ebuild
+++ b/games-action/garden/garden-1.0.9.ebuild
@@ -20,7 +20,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-dash.patch \
- "${FILESDIR}"/${P}-resources.patch
+ "${FILESDIR}"/${P}-resources.patch \
+ "${FILESDIR}"/${P}-gcc52.patch
eautoreconf
}