summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild)9
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild (renamed from dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild)9
4 files changed, 16 insertions, 20 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild
index 11eef21196e3..0714019b2155 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r3.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild
@@ -28,7 +28,10 @@ SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
LICENSE="MIT"
KEYWORDS="amd64 arm arm64"
-RESTRICT="splitdebug"
+
+# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+# bug https://bugs.gentoo.org/923430
+RESTRICT="splitdebug strip"
RDEPEND="
app-crypt/mit-krb5:0/0
@@ -131,10 +134,6 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
-
- # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
- # bug https://bugs.gentoo.org/923430
- dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
index fec8f0f1835d..3e3f048ac1ab 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r3.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
@@ -28,7 +28,10 @@ SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
LICENSE="MIT"
KEYWORDS="amd64 arm arm64"
-RESTRICT="splitdebug"
+
+# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+# bug https://bugs.gentoo.org/923430
+RESTRICT="splitdebug strip"
RDEPEND="
app-crypt/mit-krb5:0/0
@@ -132,10 +135,6 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
-
- # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
- # bug https://bugs.gentoo.org/923430
- dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild
index e2e720b4af62..06710163ef35 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r3.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild
@@ -28,7 +28,10 @@ SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
LICENSE="MIT"
KEYWORDS="amd64 arm arm64"
-RESTRICT="splitdebug"
+
+# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+# bug https://bugs.gentoo.org/923430
+RESTRICT="splitdebug strip"
RDEPEND="
app-crypt/mit-krb5:0/0
@@ -133,10 +136,6 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
-
- # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
- # bug https://bugs.gentoo.org/923430
- dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild
index b4bdad035971..81675d234044 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r2.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild
@@ -28,7 +28,10 @@ SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~arm64"
-RESTRICT="splitdebug"
+
+# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
+# bug https://bugs.gentoo.org/923430
+RESTRICT="splitdebug strip"
RDEPEND="
app-crypt/mit-krb5:0/0
@@ -133,10 +136,6 @@ src_install() {
fperms 0755 "/${dest}"
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SDK_SLOT}"
-
- # STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
- # bug https://bugs.gentoo.org/923430
- dostrip -x "/${dest}/dotnet"
}
pkg_postinst() {