summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-629_beta.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 32ecb6a9a827..bfc5c2350f15 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,3 +1,2 @@
DIST less-608.tar.gz 362346 BLAKE2B 988940745fef1222c43b0bf4edec7cc7206ded0ac5d89d3faf4dab706a249913581c2fe7aa6063cf3d717176ed07b69299d3e791ba8a60358483fe9d1bf7f7c6 SHA512 7945b7f88921832ebb1b45fba8cbb449ee0133342796b654a52c146dfff3d84db18724ee84e53349eeea6017a0ebe2d8eb5366210275981dde7bb7190118fa66
-DIST less-629-beta.tar.gz 374918 BLAKE2B 0276006cf81f310a3d25add7cfaedfd678b03f99d48b75eb462fb6dda6e171c495fa6af170257fb286a35b0d6f380136c5d37b6d9a088ee08d42d4f32033afcb SHA512 5b5d7f86b0e2d00d65257b1d27511fdab21fda52f60102f7dd6c31d1314edcf75754dc9a268c03ebfe08ffc7b88f3b7cad0fa5a9504d66b11bc13f5f52cab558
DIST less-632.tar.gz 375440 BLAKE2B 26c27a2e25882a4ce34e5e6e83bc0af784c8d4e8ac20691e0e31f1021bfb30f96e07024a6ff1ad634f7812875e0d920bd52394ccdba47a2a944ba7de92aa4c97 SHA512 5104f1fd76cdd59dfa957a61f8ccffe7c6e79345b94a5961abbd30f2d059f2b6d4b359a27dd5528993e5e1248c655439c1e4a39fd92234e4af23c7167f69f066
diff --git a/sys-apps/less/less-629_beta.ebuild b/sys-apps/less/less-629_beta.ebuild
deleted file mode 100644
index 3dc457ca05ff..000000000000
--- a/sys-apps/less/less-629_beta.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WANT_AUTOMAKE=none
-WANT_LIBTOOL=none
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/gwsw/less"
- inherit git-r3
-fi
-
-inherit autotools
-
-# Releases are usually first a beta then promoted to stable if no
-# issues were found. Upstream explicitly ask "to not generally distribute"
-# the beta versions. It's okay to keyword beta versions if they fix
-# a serious bug, but otherwise try to avoid it.
-
-MY_PV=${PV/_beta/-beta}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="Excellent text file viewer"
-HOMEPAGE="http://www.greenwoodsoftware.com/less/"
-[[ ${PV} != 9999 ]] && SRC_URI="http://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P/?beta}
-
-LICENSE="|| ( GPL-3 BSD-2 )"
-SLOT="0"
-if [[ ${PV} != 9999 && ${PV} != *_beta* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-IUSE="pcre"
-# As of 623_beta, lesstest is not included in dist tarballs
-# https://github.com/gwsw/less/issues/344
-RESTRICT="test"
-
-DEPEND="
- >=app-misc/editor-wrapper-3
- >=sys-libs/ncurses-5.2:=
- pcre? ( dev-libs/libpcre2 )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- # Per upstream README to prepare live build
- [[ ${PV} == 9999 ]] && emake -f Makefile.aut distfiles
- # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
- # https://bugs.gentoo.org/870412
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --with-regex=$(usex pcre pcre2 posix)
- --with-editor="${EPREFIX}"/usr/libexec/editor
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check VERBOSE=1
-}
-
-src_install() {
- default
-
- newbin "${FILESDIR}"/lesspipe-r1.sh lesspipe
- newenvd "${FILESDIR}"/less.envd 70less
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-483-r1" ; then
- elog "The lesspipe.sh symlink has been dropped. If you are still setting"
- elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
- elog "Colorization support has been dropped. If you want that, check out"
- elog "the new app-text/lesspipe package."
- fi
-}