summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-22.8.0.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 78ff6ce59055..30e72befe181 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,2 +1 @@
DIST black-22.10.0.gh.tar.gz 1177403 BLAKE2B c8185f1cd16bf890ad0c75a50ccf211eb8e0d50a62654abc30ff6404818c323a08551d9a79194d05df6f4f92c4c7bca43b1d317243d84542f8eda3dcc0b2895c SHA512 ec03dd7b29becaabac1393d636ba394182c4fdacc57112980c76485f05e8fdf41e23cf8dc72dfdf530a5f060e709a0bc9d60d797e897020ae036e0a5410fc4b2
-DIST black-22.8.0.gh.tar.gz 1173503 BLAKE2B 851e2dedf35871dc07caaafbffa15aa91e18640a352df717e19dc98b48134af21343e36faf90899fedd700149f988f5385c18c2d01ca330ef6e7a721cbe41a38 SHA512 f9db2079aedb14a8d9388a2c0997ffd55c74636d487ef7a3ad86fcd038a3e5d3f63168a1bca266b3e3128cd8590a641bd4259be9c238a8df968c3c085682d3b6
diff --git a/dev-python/black/black-22.8.0.ebuild b/dev-python/black/black-22.8.0.ebuild
deleted file mode 100644
index 2745c95086f2..000000000000
--- a/dev-python/black/black-22.8.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# py3.11 blocked by mypy_extensions
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="The uncompromising Python code formatter"
-HOMEPAGE="
- https://black.readthedocs.io/en/stable/
- https://github.com/psf/black/
- https://pypi.org/project/black/
-"
-SRC_URI="
- https://github.com/psf/black/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-BDEPEND="
- >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
- test? (
- >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
- dev-python/aiohttp-cors[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-pkg_postinst() {
- optfeature "blackd - HTTP API for black" "dev-python/aiohttp dev-python/aiohttp-cors"
-}