summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/pdlzip/Manifest1
-rw-r--r--app-arch/pdlzip/pdlzip-1.11.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/pdlzip/Manifest b/app-arch/pdlzip/Manifest
index ab89ec193a3b..fb4c226eae0a 100644
--- a/app-arch/pdlzip/Manifest
+++ b/app-arch/pdlzip/Manifest
@@ -1 +1,2 @@
DIST pdlzip-1.10.tar.gz 62416 BLAKE2B 7e8a4bc5793e10a819e911535149336138473b30b552e6d728b3f547e13e34540ac8fa91d84656c3feeb2816c06cd636cf3eafc5b031cca2b63e704a8f7f6ee8 SHA512 a0da45df3af68176d1ebceccba833d0d41b04750d37e90b3da6f1bdc98a41fffcb8e0ce04a296a31351aa7babd1dcaddf08f616d103970ad5fbf13e469f287ad
+DIST pdlzip-1.11.tar.gz 73641 BLAKE2B 32b59f7ce1eb70916cba96444234fa95c4c798b00f32f54c0ec51e6c6558c7b01ee118f82c011a6d642a58b11b5f270bffe21df8d9b62478b809a84abe51164a SHA512 8fc3639ab1367026d9b5185d2f9db321b1eccfb2f2f3eebc22a41b10b2a824e598dd81d9d701923a7f55943501189b11f4ec00b0187dbadd56b06e329b750075
diff --git a/app-arch/pdlzip/pdlzip-1.11.ebuild b/app-arch/pdlzip/pdlzip-1.11.ebuild
new file mode 100644
index 000000000000..521219ce7f4b
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="https://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}