summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild28
-rw-r--r--dev-libs/concurrencykit/files/concurrencykit-doc.patch24
-rw-r--r--dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch37
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild b/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild
deleted file mode 100644
index 24f79b725083..000000000000
--- a/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="ck"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A library with concurrency related algorithms and data structures in C"
-HOMEPAGE="http://concurrencykit.org"
-SRC_URI="https://github.com/concurrencykit/ck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-# libck.so name collision #616762
-# these packages have nothing in common
-RDEPEND="!sys-cluster/charm"
-
-# https://github.com/concurrencykit/ck/issues/147
-# https://github.com/concurrencykit/ck/issues/150
-PATCHES=(
- "${FILESDIR}/${PN}-glibc-2.30.patch"
- "${FILESDIR}/${PN}-doc.patch"
-)
-
-S="${WORKDIR}/${MY_P}"
diff --git a/dev-libs/concurrencykit/files/concurrencykit-doc.patch b/dev-libs/concurrencykit/files/concurrencykit-doc.patch
deleted file mode 100644
index 40aa466bb4e6..000000000000
--- a/dev-libs/concurrencykit/files/concurrencykit-doc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/doc/Makefile.in b/doc/Makefile.in
-index cbad704..f476925 100644
---- a/doc/Makefile.in
-+++ b/doc/Makefile.in
-@@ -1,7 +1,7 @@
- .PHONY: clean install uninstall
-
- MANDIR=@MANDIR@
--GZIP=@GZIP@
-+GZIP=/bin/echo
- GZIP_SUFFIX=.3@GZIP_SUFFIX@
- BUILD_DIR=@BUILD_DIR@
- SRC_DIR=@SRC_DIR@
-@@ -206,7 +206,9 @@ refcheck:
-
- install:
- mkdir -p $(DESTDIR)/$(MANDIR)/man3 || exit
-- cp *$(GZIP_SUFFIX) $(DESTDIR)/$(MANDIR)/man3 || exit
-+ for target in $(OBJECTS); do \
-+ cp -v $$target $(DESTDIR)/$(MANDIR)/man3/$$target.3 || exit; \
-+ done
-
- uninstall:
- for target in $(OBJECTS); do \
diff --git a/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch b/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch
deleted file mode 100644
index 452421c63125..000000000000
--- a/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/regressions/common.h b/regressions/common.h
-index 6e53483d..9cdc690a 100644
---- a/regressions/common.h
-+++ b/regressions/common.h
-@@ -267,13 +267,11 @@ struct affinity {
- #define AFFINITY_INITIALIZER {0, 0}
-
- #ifdef __linux__
--#ifndef gettid
- static pid_t
--gettid(void)
-+common_gettid(void)
- {
- return syscall(__NR_gettid);
- }
--#endif /* gettid */
-
- CK_CC_UNUSED static int
- aff_iterate(struct affinity *acb)
-@@ -285,7 +283,7 @@ aff_iterate(struct affinity *acb)
- CPU_ZERO(&s);
- CPU_SET(c % CORES, &s);
-
-- if (sched_setaffinity(gettid(), sizeof(s), &s) != 0)
-+ if (sched_setaffinity(common_gettid(), sizeof(s), &s) != 0)
- perror("WARNING: Could not affine thread");
-
- return 0;
-@@ -300,7 +298,7 @@ aff_iterate_core(struct affinity *acb, unsigned int *core)
- CPU_ZERO(&s);
- CPU_SET((*core) % CORES, &s);
-
-- if (sched_setaffinity(gettid(), sizeof(s), &s) != 0)
-+ if (sched_setaffinity(common_gettid(), sizeof(s), &s) != 0)
- perror("WARNING: Could not affine thread");
-
- return 0;