summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/marco/marco-1.26.2-r1.ebuild9
-rw-r--r--x11-wm/marco/marco-1.28.1-r1.ebuild7
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-wm/marco/marco-1.26.2-r1.ebuild b/x11-wm/marco/marco-1.26.2-r1.ebuild
index d0d40b051f8e..bd1e415ad436 100644
--- a/x11-wm/marco/marco-1.26.2-r1.ebuild
+++ b/x11-wm/marco/marco-1.26.2-r1.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MATE2_LA_PUNT="yes"
+# For script meson_post_install.py
+# Bug 906826, tracker bug 762406
+PYTHON_COMPAT=( python3_{10..13} )
-inherit mate meson
+inherit mate meson python-any-r1
KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
@@ -42,6 +45,8 @@ COMMON_DEPEND="
xinerama? ( x11-libs/libXinerama )
"
+DEPEND="${PYTHON_DEPS}"
+
RDEPEND="${COMMON_DEPEND}
gnome-extra/zenity
>=mate-base/mate-desktop-1.20.0
diff --git a/x11-wm/marco/marco-1.28.1-r1.ebuild b/x11-wm/marco/marco-1.28.1-r1.ebuild
index bb7c264be6aa..6240ace59fd1 100644
--- a/x11-wm/marco/marco-1.28.1-r1.ebuild
+++ b/x11-wm/marco/marco-1.28.1-r1.ebuild
@@ -4,8 +4,11 @@
EAPI=8
MATE2_LA_PUNT="yes"
+# For script meson_post_install.py
+# Bug 906826, tracker bug 762406
+PYTHON_COMPAT=( python3_{10..13} )
-inherit mate meson
+inherit mate meson python-any-r1
MINOR=$(($(ver_cut 2) % 2))
if [[ ${MINOR} -eq 0 ]]; then
@@ -46,6 +49,8 @@ COMMON_DEPEND="
xinerama? ( x11-libs/libXinerama )
"
+DEPEND="${PYTHON_DEPS}"
+
RDEPEND="${COMMON_DEPEND}
gnome-extra/zenity
virtual/libintl