summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gopass/gopass-1.12.1.ebuild')
-rw-r--r--app-admin/gopass/gopass-1.12.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-admin/gopass/gopass-1.12.1.ebuild b/app-admin/gopass/gopass-1.12.1.ebuild
index 38cfccc4f4f0..e61d89168056 100644
--- a/app-admin/gopass/gopass-1.12.1.ebuild
+++ b/app-admin/gopass/gopass-1.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit go-module
+inherit go-module optfeature
EGO_SUM=(
"filippo.io/age v1.0.0-beta7"
@@ -162,7 +162,7 @@ LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-RESTRICT="test"
+RESTRICT="strip test"
DEPEND=">=dev-lang/go-1.16"
RDEPEND="
@@ -174,3 +174,10 @@ src_install() {
emake install DESTDIR="${ED}/usr"
einstalldocs
}
+
+pkg_postinst() {
+ optfeature "browser integration" app-admin/gopass-jsonapi
+ optfeature "git credentials helper" app-admin/git-credential-gopass
+ optfeature "haveibeenpwnd.com integration" app-admin/gopass-hibp
+ optfeature "summon secrets helper" app-admin/gopass-summon-provider
+}