summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/showconsole/Manifest1
-rw-r--r--app-admin/showconsole/files/1.07-no-TIOCGDEV.patch27
-rw-r--r--app-admin/showconsole/files/bootlogger.sh33
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-build.patch13
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch17
-rw-r--r--app-admin/showconsole/files/showconsole-1.08-quiet.patch34
-rw-r--r--app-admin/showconsole/metadata.xml8
-rw-r--r--app-admin/showconsole/showconsole-1.08.ebuild41
8 files changed, 0 insertions, 174 deletions
diff --git a/app-admin/showconsole/Manifest b/app-admin/showconsole/Manifest
deleted file mode 100644
index 00ea82531c82..000000000000
--- a/app-admin/showconsole/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST showconsole-1.08.tar.bz2 20821 SHA256 3f3c1462c21db37054e109bbda23490de759311e8d182a3565f1ae8926d10e27 SHA512 b80c83350408211ba3e069befb2cc9ee53bfdde5ddeb43213bd02a70d65cf987c223cb22dabb687b9a21ccf7312bef17dee968d1d1cd6c66fc0b1ad6e0bd02b2 WHIRLPOOL 7ed12042b45a8771729d254ffd6c2ab7db0174b3e5c485bfd088faff7455cd45a2df4341dc6390106857becff850e3091ae93edcfe87cc2be81c36f1893a4583
diff --git a/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch b/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch
deleted file mode 100644
index 49a09cea2155..000000000000
--- a/app-admin/showconsole/files/1.07-no-TIOCGDEV.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- showconsole-1.07/libconsole.c.orig 2004-12-03 21:57:24.507411240 -0500
-+++ showconsole-1.07/libconsole.c 2004-12-03 21:59:26.820816776 -0500
-@@ -1021,13 +1021,8 @@
- char * name = NULL;
- DIR * dev;
-
--#ifdef TIOCGDEV
-+#define TIOCGDEV _IOR('T',0x32, unsigned int)
- if (ioctl (0, TIOCGDEV, &tty) < 0) {
-- if (errno == EINVAL && !getenv("NOTIOCGDEV"))
-- warn("Warning: the ioctl TIOCGDEV is not known by the kernel\n");
--#else
--# error The ioctl TIOCGDEV is not defined (SuSE TIOCGDEV patch is missed)
--#endif
- if (!(name = ttyname(0)) || !strcmp(name, "/dev/console"))
- tty = fallback(pid, ppid);
- else {
-@@ -1036,9 +1031,7 @@
- name = lnk;
- goto out;
- }
--#ifdef TIOCGDEV
- }
--#endif
-
- if (!(dev = opendir("/dev")))
- error("can not opendir(/dev): %s\n", STRERR);
diff --git a/app-admin/showconsole/files/bootlogger.sh b/app-admin/showconsole/files/bootlogger.sh
deleted file mode 100644
index bea8568a0de6..000000000000
--- a/app-admin/showconsole/files/bootlogger.sh
+++ /dev/null
@@ -1,33 +0,0 @@
-# /lib/rcscripts/addons/bootlogger.sh: Handle logging of output at boot
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-if [[ -x /sbin/blogd ]] ; then
-
-bootlog() {
- [[ ${RC_BOOTLOG} == "yes" ]] || return 0
-
- local opt=$1
- shift
- case ${opt} in
- start) blogd_start "$@";;
- sync) blogd_sync "$@";;
- quit) blogd_quit "$@";;
- esac
-}
-
-blogd_start() {
- /sbin/blogd -q
-}
-
-blogd_sync() {
- echo > /var/log/boot.msg
- killall -IO blogd
-}
-
-blogd_quit() {
- killall -QUIT blogd
-}
-
-fi
diff --git a/app-admin/showconsole/files/showconsole-1.08-build.patch b/app-admin/showconsole/files/showconsole-1.08-build.patch
deleted file mode 100644
index 520a1607430b..000000000000
--- a/app-admin/showconsole/files/showconsole-1.08-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/143768
-
---- showconsole-1.08/Makefile
-+++ showconsole-1.08/Makefile
-@@ -37,7 +37,7 @@
- RM = rm -f
- MKDIR = mkdir -p
- RMDIR = rm -rf
-- INSTBINFLAGS = -s -m 0700
-+ INSTBINFLAGS = -m 0700
- INSTBIN = install $(INSTBINFLAGS)
- INSTDOCFLAGS = -c -m 0444
- INSTDOC = install $(INSTDOCFLAGS)
diff --git a/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch b/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch
deleted file mode 100644
index 7592b5ef8e25..000000000000
--- a/app-admin/showconsole/files/showconsole-1.08-no-pthread-yield.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://sourceware.org/cgi-bin/cvsweb.cgi/~checkout~/linuxthreads/linuxthreads/FAQ.html?rev=1.2.2.1&content-type=text/html&cvsroot=glibc#E
-
-use sched_yield, not pthread_yield
-
-http://bugs.gentoo.org/119762
-
---- libconsole.c
-+++ libconsole.c
-@@ -439,7 +439,7 @@
- ret = 0;
- }
- } else
-- pthread_yield();
-+ sched_yield();
-
- return ret;
- }
diff --git a/app-admin/showconsole/files/showconsole-1.08-quiet.patch b/app-admin/showconsole/files/showconsole-1.08-quiet.patch
deleted file mode 100644
index d03996056a5e..000000000000
--- a/app-admin/showconsole/files/showconsole-1.08-quiet.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- blogd.c
-+++ blogd.c
-@@ -183,6 +183,7 @@
- {
- int fd, flags;
- int ptm, pts, cntrtty = 1;
-+ int quiet = 0;
- pid_t pid, ppid = getppid();
- char ptsname[NAME_MAX+1];
- struct termios t;
-@@ -193,7 +194,14 @@
- myname = basename(*argv);
-
- if (argc > 2)
-- error("Too many args; usage: %s [/dev/tty<X>]\n", myname);
-+ error("Too many args; usage: %s [-q] [/dev/tty<X>]\n", myname);
-+
-+ if (argc > 1 && strcmp(argv[1], "-q") == 0) {
-+ quiet = 1;
-+ --argc;
-+ if (argc > 2)
-+ argv[1] = argv[2];
-+ }
-
- if (argc == 2)
- tty = argv[1];
-@@ -282,6 +289,7 @@
- close(pts);
- close(ptm);
- close(fd);
-+ if (!quiet)
- fprintf(stdout, "\rBoot logging started on %s(%s) at %.24s\n", tty, name, stt);
- fflush(stdout);
- exit(0);
diff --git a/app-admin/showconsole/metadata.xml b/app-admin/showconsole/metadata.xml
deleted file mode 100644
index 56c124413057..000000000000
--- a/app-admin/showconsole/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
-</pkgmetadata>
diff --git a/app-admin/showconsole/showconsole-1.08.ebuild b/app-admin/showconsole/showconsole-1.08.ebuild
deleted file mode 100644
index 5a623227f73c..000000000000
--- a/app-admin/showconsole/showconsole-1.08.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# This tarball is extracted from SuSe's sysvinit-2.86-#.src.rpm
-# You can find said src rpm via opensuse.org:
-# https://mirrors.kernel.org/opensuse/distribution/SL-OSS-*/inst-source/suse/src/
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="small daemon for logging console output during boot"
-HOMEPAGE="http://www.novell.com/linux/suse/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh ~sparc x86"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/1.07-no-TIOCGDEV.patch
- epatch "${FILESDIR}"/${P}-quiet.patch
- epatch "${FILESDIR}"/${P}-no-pthread-yield.patch #119762
- epatch "${FILESDIR}"/${P}-build.patch #143768
-}
-
-src_compile() {
- emake COPTS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "install failed"
- insinto /$(get_libdir)/rcscripts/addons
- doins "${FILESDIR}"/bootlogger.sh || die "rcscript addon"
- rmdir "${D}"/usr/lib/lsb || die
- dodoc showconsole-*.lsm README
-}