summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libmd')
-rw-r--r--app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch56
-rw-r--r--app-crypt/libmd/libmd-1.0.3-r2.ebuild (renamed from app-crypt/libmd/libmd-1.0.3-r1.ebuild)15
2 files changed, 67 insertions, 4 deletions
diff --git a/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch b/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch
new file mode 100644
index 000000000000..77edac0115f0
--- /dev/null
+++ b/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch
@@ -0,0 +1,56 @@
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -41,7 +41,7 @@
+ $(nil)
+
+ $(md2_FUNCS): md2.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md2.3 $@.3
+
+ md4_FUNCS = \
+ MD4Transform \
+@@ -56,7 +56,7 @@
+ $(nil)
+
+ $(md4_FUNCS): md4.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md4.3 $@.3
+
+ md5_FUNCS = \
+ MD5Transform \
+@@ -71,7 +71,7 @@
+ $(nil)
+
+ $(md5_FUNCS): md5.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md5.3 $@.3
+
+ rmd160_FUNCS = \
+ RMD160Transform \
+@@ -86,7 +86,7 @@
+ $(nil)
+
+ $(rmd160_FUNCS): rmd160.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f rmd160.3 $@.3
+
+ sha1_FUNCS = \
+ SHA1Transform \
+@@ -101,7 +101,7 @@
+ $(nil)
+
+ $(sha1_FUNCS): sha1.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f sha1.3 $@.3
+
+ sha2_FUNCS = \
+ SHA256Init \
+@@ -134,7 +134,7 @@
+ $(nil)
+
+ $(sha2_FUNCS): sha2.3
+- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
++ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f sha2.3 $@.3
+
+ digest_FUNCS = \
+ $(md2_FUNCS) \
diff --git a/app-crypt/libmd/libmd-1.0.3-r1.ebuild b/app-crypt/libmd/libmd-1.0.3-r2.ebuild
index b6ab06313260..936aefd8f401 100644
--- a/app-crypt/libmd/libmd-1.0.3-r1.ebuild
+++ b/app-crypt/libmd/libmd-1.0.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Message Digest functions from BSD systems"
HOMEPAGE="https://www.hadrons.org/software/libmd/"
@@ -13,11 +13,18 @@ LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+PATCHES=( "${FILESDIR}"/${P}-out-of-source.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}
-multilib_src_install() {
- default
- find "${ED}" -type f -name "*.la" -delete || die
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
}