summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vis/vis-9999.ebuild')
-rw-r--r--app-editors/vis/vis-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-editors/vis/vis-9999.ebuild b/app-editors/vis/vis-9999.ebuild
index 600b5efb0576..7af054d1607e 100644
--- a/app-editors/vis/vis-9999.ebuild
+++ b/app-editors/vis/vis-9999.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3
+LUA_COMPAT=( lua5-2 lua5-3 )
+
+inherit lua-single git-r3 eutils
DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
HOMEPAGE="https://github.com/martanne/vis"
@@ -10,14 +12,13 @@ EGIT_REPO_URI="https://github.com/martanne/vis.git"
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="+ncurses selinux test tre"
+IUSE="+ncurses +lua selinux test tre"
RESTRICT="!test? ( test )"
# - Known to also work with NetBSD curses
-# - ::lua package done for using >=dev-lang/lua-5.2
-# which is needed for syntax highlighting and settings but masked in ::gentoo
DEPEND="dev-libs/libtermkey
ncurses? ( sys-libs/ncurses:0= )
+ lua? ( ${LUA_DEPS} )
tre? ( dev-libs/tre:= )"
RDEPEND="${DEPEND}
app-eselect/eselect-vi"
@@ -34,6 +35,7 @@ src_configure() {
./configure \
--prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable lua) \
$(use_enable ncurses curses) \
$(use_enable selinux) \
$(use_enable tre) || die
@@ -50,4 +52,5 @@ pkg_postrm() {
pkg_postinst() {
update_symlinks
+ optfeature "syntax highlighting support" dev-lua/lpeg
}