summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/slirp4netns')
-rw-r--r--app-emulation/slirp4netns/Manifest1
-rw-r--r--app-emulation/slirp4netns/slirp4netns-1.1.8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/slirp4netns/Manifest b/app-emulation/slirp4netns/Manifest
index 03bceefba8ae..33e69c6c548b 100644
--- a/app-emulation/slirp4netns/Manifest
+++ b/app-emulation/slirp4netns/Manifest
@@ -1 +1,2 @@
DIST slirp4netns-1.1.4.tar.gz 55346 BLAKE2B 86716ec9f42ae0087e9e7d142683f53b986275bce20b5ab0a33d0cdd63778adfeeadc86e5abb52d4a7e3e89baa0440c1a99bde920eeb2ed5293046e451d8ad01 SHA512 a6a26c55bdd4f50e668f7feeee3cd1d077e1ca9bd5bad5bbb8c47b15d366af4b1f2900241bedcd5a974a7597f43b17f970662271ec1987fbb6291c50470fa0a8
+DIST slirp4netns-1.1.8.tar.gz 58022 BLAKE2B cb65af6a5298411c158dd3da8160f8e4999ce5cb6bafc85f233d4d64a58c545ff7e9db21501f718ce7990d2497a6960853ecb9ff548859b1be19f3d74e86610b SHA512 28b2dd73cfd0a0fc71338c55a7f4ae448456620a0d27eb1e7c79f2d58da2a90f2f9af363c9abf5148d4d6435f69ea26809e5f20721fec5daf4c9897bb29c3547
diff --git a/app-emulation/slirp4netns/slirp4netns-1.1.8.ebuild b/app-emulation/slirp4netns/slirp4netns-1.1.8.ebuild
new file mode 100644
index 000000000000..ab7c659fa363
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-1.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libpcre:=
+ net-libs/libslirp:=
+ sys-libs/libseccomp:=
+ sys-libs/libcap:="
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RESTRICT="test"
+
+src_prepare() {
+ # Respect AR variable for bug 722162.
+ sed -e 's|^AC_PROG_CC$|AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])\nAC_PROG_AR\n\0|' \
+ -i configure.ac || die
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+ fi
+}