summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ansifilter/ansifilter-1.11.ebuild')
-rw-r--r--app-text/ansifilter/ansifilter-1.11.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-text/ansifilter/ansifilter-1.11.ebuild b/app-text/ansifilter/ansifilter-1.11.ebuild
new file mode 100644
index 000000000000..c933334d7554
--- /dev/null
+++ b/app-text/ansifilter/ansifilter-1.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs qt4-r2
+
+DESCRIPTION="Handles text files containing ANSI terminal escape codes"
+HOMEPAGE="http://www.andre-simon.de/"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+RDEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ myopts=(
+ "CC=$(tc-getCXX)"
+ "CFLAGS=${CFLAGS} -c"
+ "LDFLAGS=${LDFLAGS}"
+ "DESTDIR=${ED}"
+ "PREFIX=${EPREFIX}/usr"
+ "doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
+ )
+}
+
+src_prepare() {
+ # bug 431452
+ rm src/qt-gui/moc_mydialog.cpp || die
+}
+
+src_compile() {
+ emake -f makefile "${myopts[@]}"
+ if use qt4 ; then
+ cd src/qt-gui
+ eqmake4
+ emake
+ fi
+}
+
+src_install() {
+ emake -f makefile "${myopts[@]}" install
+ use qt4 && emake -f makefile "${myopts[@]}" install-gui
+}