summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/hunspell/Manifest1
-rw-r--r--app-text/hunspell/hunspell-1.6.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-text/hunspell/Manifest b/app-text/hunspell/Manifest
index c1c78e505c79..6c8d1fa5e2dd 100644
--- a/app-text/hunspell/Manifest
+++ b/app-text/hunspell/Manifest
@@ -4,3 +4,4 @@ DIST hunspell-1.4.2.tar.gz 1000676 SHA256 b6a0b23d083e0130f8c561cca8c980814ba657
DIST hunspell-1.5.3.tar.gz 1110837 SHA256 1175666ec79b37fa6d3e6fda454414cecafeb537f078dda40eed96031e6fd5cc SHA512 1f3d7639ec5995bb0fa21a4c728145673fcf412b11323176e02d84a08f49f3ad29660253a6bd55856a358c8df75cb05a2465ad00034575490e3c618ffe937ba6 WHIRLPOOL 0a2d59fa1e421127e2ed7e6edc94868a9838d72cfce54a21053b2e53a64e29ffd0a2d31b22d2daef6047df78a92d7e55664797b0c1cba6e068f7249225e11ef2
DIST hunspell-1.5.4.tar.gz 1110858 SHA256 852c01a2e3b87eb1f2adb5261466608ba79f1f950202e18a2a1735de5098fc59 SHA512 cda1612af2984bb28f7cf42ed2c81aac0e8ff0d0f740b3607a75f076d3478960f0c1d6b52a06fb0afbacfc1fce103da1ca2438dbe62e7abb46f70231347357bd WHIRLPOOL fe350cc0a22606c036e300ce8da0b1af36950778548d44bc6075ceb8da3aad0d682e2e12795bb1d52bba784910947ea9ed5c0ce07fdbb19524309b01b8898e9a
DIST hunspell-1.6.0.tar.gz 699377 SHA256 512e7d2ee69dad0b35ca011076405e56e0f10963a02d4859dbcc4faf53ca68e2 SHA512 d13e0384654f98f87de61d3d6ec03fe4a0e972b49b7e220083c72c2dd99d169a4854160f7068baa34fe4d4bd85fa5c24b56587827b946fb072a2085173801ca9 WHIRLPOOL 9ab935e0a94e3f7ae02a9cf27b65c7f74b4eb13a2a447d05f94b3864d88b6d7c5bf93756433cc459506721e2327e83bb7151a638a9c2d2bc46a59a16889494cf
+DIST hunspell-1.6.1.tar.gz 706893 SHA256 30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49 SHA512 39b096ec1f5226f13eaf241647fc9b49a6dad04945ae0bcdc61ba845d66d67d64a72ba4287b6f376b5ad053b5d0e1d42a42415c30521c50693f0544718029458 WHIRLPOOL 3013fc1538d01650ffc233f53f000cab7c797be7c712d7609598f0c5807eacf5a13215bce7176da6578e5e78825525864f833db56dbe64362431d3680fbd6b00
diff --git a/app-text/hunspell/hunspell-1.6.1.ebuild b/app-text/hunspell/hunspell-1.6.1.ebuild
new file mode 100644
index 000000000000..7af9164d711e
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.6.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib autotools flag-o-matic versionator
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0/$(get_version_component_range 1-2)"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ readline? ( sys-libs/readline:= )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id
+is it km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
+
+PDEPEND="app-dicts/myspell-en"
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang}"
+ case ${lang} in
+ de-1901) dict="de_1901" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
+done
+unset dict lang LANGS
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell
+ AUTHORS.myspell README.myspell license.myspell README.md
+)
+
+PATCHES=(
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ "${FILESDIR}/${PN}-1.6.0-renameexes.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # missing somehow, and I am too lazy to fix it properly
+ [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
+
+ # I wanted to put the include files in /usr/include/hunspell.
+ # You can do that, libreoffice can find them anywhere, just
+ # ping me when you do so ; -- scarabeus
+ econf \
+ $(use_enable nls) \
+ $(use_with ncurses ui) \
+ $(use_with readline readline) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ prune_libtool_files --all
+
+ #342449
+ pushd "${ED}"/usr/$(get_libdir)/ >/dev/null
+ ln -s lib${PN}{-$(get_major_version).$(get_version_component_range 2).so.0.0.0,.so}
+ popd >/dev/null
+}