summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
index 9f123f017901..674acf4c9f29 100644
--- a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
+++ b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
@@ -8,19 +8,19 @@ inherit cmake
DESCRIPTION="The ANTLR 4 C++ Runtime"
HOMEPAGE="https://www.antlr.org/"
SRC_URI="https://www.antlr.org/download/antlr4-cpp-runtime-${PV}-source.zip -> ${P}.zip"
+S="${WORKDIR}"
+
LICENSE="BSD"
SLOT="4"
KEYWORDS="amd64 ~arm ~ppc x86"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_prepare() {
sed -i -e "s#DESTINATION lib#DESTINATION $(get_libdir)#" \
"${S}"/runtime/CMakeLists.txt || die "failed sed"
- sed -i -e "s#share/doc/libantlr4#share/doc/${P}#g" \
+ sed -i -e "s#share/doc/libantlr4#share/doc/${PF}#g" \
"${S}"/CMakeLists.txt || die "failed sed"
cmake_src_prepare