summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/alsa-mixer')
-rw-r--r--dev-haskell/alsa-mixer/Manifest3
-rw-r--r--dev-haskell/alsa-mixer/alsa-mixer-0.1.2-r2.ebuild26
-rw-r--r--dev-haskell/alsa-mixer/alsa-mixer-0.2.0.1.ebuild28
-rw-r--r--dev-haskell/alsa-mixer/alsa-mixer-0.2.0.2.ebuild28
-rw-r--r--dev-haskell/alsa-mixer/metadata.xml11
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-haskell/alsa-mixer/Manifest b/dev-haskell/alsa-mixer/Manifest
new file mode 100644
index 000000000000..657d40b45499
--- /dev/null
+++ b/dev-haskell/alsa-mixer/Manifest
@@ -0,0 +1,3 @@
+DIST alsa-mixer-0.1.2.tar.gz 6901 SHA256 081f3a62f83a269d72e0b0fac8bae8c81e9ec342d592fa25abe57f7206cf4414 SHA512 fae4c1f9b65d47a55b2674b04c38f46fc440222c7215b1bb95de14b7c642068392a73c0cebb08b4e3cf49ab824ec78a57d942279364e28bfa45be471f1b8fdfa WHIRLPOOL de98a902fe2d33e019ab57f90024c1caea462089385f870e6b071c76a25ae266ca81e55470bef5003abc7edc1668c67f0ef43ee3edaa1e9b8f3e86b436699b10
+DIST alsa-mixer-0.2.0.1.tar.gz 7176 SHA256 197a98c9f5da86ea3f93ac570a0587ab0a754ee70c7189dbbca315c4099f068c SHA512 74b0f3b2f4e76130a0e6afdf1d9bb0b64e2bcc192866a6c17dd737ea4e63bf69b53d548a6e1ba15c509751bb769db6b202e08343b25ed7872f97b00a5ee3f6ac WHIRLPOOL d6b1ae3594347e4d9b7d18a8840ff1584d0bd68a88d26414fad6434da17c1d424541d2a568b5a9e647c75134606518de44fe9abf487141de907baf508700469f
+DIST alsa-mixer-0.2.0.2.tar.gz 7184 SHA256 139e837a47c31c7b6e41c7ffead7558fde8cde468b91f27d5a19a97490154c87 SHA512 f480008cfe5dd87e01b22bd3af44caee17095dc1be2e535acdca4cb2b56cd87fb086b8222ae10b1ca866818469dff7309ea6e0b7ec22ad83cdff07e6a702aa76 WHIRLPOOL 08412de6b32811cf9634751acf208b55fd3c21cb8bdd0202ae9a1dbcd4738ec397d8c94f4cc5ab34c74986897ed11db6b4b635e1c68f1cde5370acb30a64643c
diff --git a/dev-haskell/alsa-mixer/alsa-mixer-0.1.2-r2.ebuild b/dev-haskell/alsa-mixer/alsa-mixer-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..ffeb989df7e0
--- /dev/null
+++ b/dev-haskell/alsa-mixer/alsa-mixer-0.1.2-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ALSA simple mixer API"
+HOMEPAGE="http://hackage.haskell.org/package/alsa-mixer"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/alsa-core-0.5*:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-haskell/c2hs
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.1.ebuild b/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.1.ebuild
new file mode 100644
index 000000000000..2a5054ae58b7
--- /dev/null
+++ b/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ALSA simple mixer API"
+HOMEPAGE="https://github.com/ttuegel/alsa-mixer"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/alsa-core-0.5:=[profile?] <dev-haskell/alsa-core-0.6:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ media-libs/alsa-lib
+"
+DEPEND="${RDEPEND}
+ dev-haskell/c2hs
+ >=dev-haskell/cabal-1.16.0
+"
diff --git a/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.2.ebuild b/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.2.ebuild
new file mode 100644
index 000000000000..01a6b1cd9da7
--- /dev/null
+++ b/dev-haskell/alsa-mixer/alsa-mixer-0.2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ALSA simple mixer API"
+HOMEPAGE="https://github.com/ttuegel/alsa-mixer"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/alsa-core-0.5:=[profile?] <dev-haskell/alsa-core-0.6:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ media-libs/alsa-lib
+"
+DEPEND="${RDEPEND}
+ dev-haskell/c2hs
+ >=dev-haskell/cabal-1.16.0
+"
diff --git a/dev-haskell/alsa-mixer/metadata.xml b/dev-haskell/alsa-mixer/metadata.xml
new file mode 100644
index 000000000000..ccdb996a4dab
--- /dev/null
+++ b/dev-haskell/alsa-mixer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides haskell bindings to the ALSA simple mixer API.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ttuegel/alsa-mixer</remote-id>
+ </upstream>
+</pkgmetadata>