summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/tcl/files')
-rw-r--r--dev-lang/tcl/files/tcl-8.4.15-tclm4-soname.patch11
-rw-r--r--dev-lang/tcl/files/tcl-8.4.16-multilib.patch21
-rw-r--r--dev-lang/tcl/files/tcl-8.4.9-strtod.patch11
-rw-r--r--dev-lang/tcl/files/tcl-8.5.10-conf.patch26
-rw-r--r--dev-lang/tcl/files/tcl-8.5.13-autopath.patch19
-rw-r--r--dev-lang/tcl/files/tcl-8.5.13-conf.patch20
-rw-r--r--dev-lang/tcl/files/tcl-8.5.13-multilib.patch12
-rw-r--r--dev-lang/tcl/files/tcl-8.5.14-conf.patch11
-rw-r--r--dev-lang/tcl/files/tcl-8.5.9-gentoo-fbsd.patch13
-rw-r--r--dev-lang/tcl/files/tcl-8.5_alpha6-multilib.patch24
-rw-r--r--dev-lang/tcl/files/tcl-8.5_alpha6-tclm4-soname.patch11
-rw-r--r--dev-lang/tcl/files/tcl-8.6.1-conf.patch11
-rw-r--r--dev-lang/tcl/files/tcl-configure-LANG.patch41
13 files changed, 231 insertions, 0 deletions
diff --git a/dev-lang/tcl/files/tcl-8.4.15-tclm4-soname.patch b/dev-lang/tcl/files/tcl-8.4.15-tclm4-soname.patch
new file mode 100644
index 000000000000..4f2dce927d5e
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.4.15-tclm4-soname.patch
@@ -0,0 +1,11 @@
+--- tcl8.4.15.orig/unix/tcl.m4 2007-05-25 05:40:13.000000000 +0900
++++ tcl8.4.15/unix/tcl.m4 2007-07-20 08:40:41.000000000 +0900
+@@ -1345,7 +1345,7 @@
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+ if test "$have_dl" = yes; then
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-8.4.16-multilib.patch b/dev-lang/tcl/files/tcl-8.4.16-multilib.patch
new file mode 100644
index 000000000000..59d1b8af2f1e
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.4.16-multilib.patch
@@ -0,0 +1,21 @@
+diff -Naur tcl8.4.16.orig/unix/configure.in tcl8.4.16/unix/configure.in
+--- tcl8.4.16.orig/unix/configure.in 2007-09-22 02:07:02.000000000 +0900
++++ tcl8.4.16/unix/configure.in 2007-12-15 10:43:16.000000000 +0900
+@@ -570,7 +570,7 @@
+ DBGX='${TCL_DBGX}'
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+-TCL_LIBRARY='$(prefix)/lib/tcl$(VERSION)'
++TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+ PRIVATE_INCLUDE_DIR='$(includedir)'
+ HTML_DIR='$(DISTDIR)/html'
+
+@@ -669,7 +669,7 @@
+ if test "$FRAMEWORK_BUILD" = "1" ; then
+ test -z "$TCL_PACKAGE_PATH" && \
+ TCL_PACKAGE_PATH="~/Library/Tcl /Library/Tcl /Network/Library/Tcl /System/Library/Tcl ~/Library/Frameworks /Library/Frameworks /Network/Library/Frameworks /System/Library/Frameworks"
+-elif test "$prefix" != "$exec_prefix"; then
++elif test "$prefix" != "$exec_prefix" -o "${libdir}" != "${prefix}/lib"; then
+ TCL_PACKAGE_PATH="${libdir} ${prefix}/lib ${TCL_PACKAGE_PATH}"
+ else
+ TCL_PACKAGE_PATH="${prefix}/lib ${TCL_PACKAGE_PATH}"
diff --git a/dev-lang/tcl/files/tcl-8.4.9-strtod.patch b/dev-lang/tcl/files/tcl-8.4.9-strtod.patch
new file mode 100644
index 000000000000..a9974546b741
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.4.9-strtod.patch
@@ -0,0 +1,11 @@
+--- tcl8.4.9/compat/strtod.c 2002-02-25 16:26:12.000000000 +0200
++++ tcl8.4.9/compat/strtod.c 2005-05-30 08:55:18.000000000 +0300
+@@ -24,6 +24,8 @@
+ #define NULL 0
+ #endif
+
++#undef strtod
++
+ static int maxExponent = 511; /* Largest possible base 10 exponent. Any
+ * exponent larger than this will already
+ * produce underflow or overflow, so there's
diff --git a/dev-lang/tcl/files/tcl-8.5.10-conf.patch b/dev-lang/tcl/files/tcl-8.5.10-conf.patch
new file mode 100644
index 000000000000..dd90b06a6e55
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.10-conf.patch
@@ -0,0 +1,26 @@
+--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
++++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
+@@ -1427,12 +1427,12 @@ dnl AC_CHECK_TOOL(AR, ar)
+ # get rid of the warnings.
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
+ AS_IF([test $doRpath = yes], [
+- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'])
++ CC_SEARCH_FLAGS=''])
+ LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
+ AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
+ AS_IF([test $do64bit = yes], [
+@@ -1464,7 +1464,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ SHLIB_CFLAGS="-fPIC"
+ SHLIB_SUFFIX=".so"
+
+- SHLIB_LD='${CC} -shared'
++ SHLIB_LD='${CC} ${CFLAGS} -shared -fPIC'
+ DL_OBJS=""
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-8.5.13-autopath.patch b/dev-lang/tcl/files/tcl-8.5.13-autopath.patch
new file mode 100644
index 000000000000..77f0ca6ced0c
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.13-autopath.patch
@@ -0,0 +1,19 @@
+ unix/configure.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/unix/configure.in b/unix/configure.in
+index 65f712a..b606b74 100755
+--- a/unix/configure.in
++++ b/unix/configure.in
+@@ -840,9 +840,9 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
+ test -z "$TCL_MODULE_PATH" && \
+ TCL_MODULE_PATH="~/Library/Tcl /Library/Tcl /System/Library/Tcl"
+ elif test "$prefix/lib" != "$libdir"; then
+- TCL_PACKAGE_PATH="${libdir} ${prefix}/lib ${TCL_PACKAGE_PATH}"
++ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${prefix}/share/tcl8.5 ${libdir}/tk8.5 ${prefix}/share/tk8.5 ${TCL_PACKAGE_PATH}"
+ else
+- TCL_PACKAGE_PATH="${prefix}/lib ${TCL_PACKAGE_PATH}"
++ TCL_PACKAGE_PATH="${libdir}/tcl8.5 ${prefix}/share/tcl8.5 ${libdir}/tk8.5 ${prefix}/share/tk8.5 ${TCL_PACKAGE_PATH}"
+ fi
+
+ #--------------------------------------------------------------------
diff --git a/dev-lang/tcl/files/tcl-8.5.13-conf.patch b/dev-lang/tcl/files/tcl-8.5.13-conf.patch
new file mode 100644
index 000000000000..2d7493c3b3d6
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.13-conf.patch
@@ -0,0 +1,20 @@
+--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
++++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
+@@ -1427,7 +1427,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ # get rid of the warnings.
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
+@@ -1464,7 +1464,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ SHLIB_CFLAGS="-fPIC"
+ SHLIB_SUFFIX=".so"
+
+- SHLIB_LD='${CC} -shared'
++ SHLIB_LD='${CC} ${CFLAGS} -shared -fPIC'
+ DL_OBJS=""
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-8.5.13-multilib.patch b/dev-lang/tcl/files/tcl-8.5.13-multilib.patch
new file mode 100644
index 000000000000..de1580ce55bd
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.13-multilib.patch
@@ -0,0 +1,12 @@
+diff -Naur tcl8.5a6.orig/unix/configure.in tcl8.5a6/unix/configure.in
+--- tcl8.5a6.orig/unix/configure.in 2007-04-27 02:33:51.000000000 +0900
++++ tcl8.5a6/unix/configure.in 2007-05-16 10:27:25.000000000 +0900
+@@ -645,7 +645,7 @@
+
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+-TCL_LIBRARY='$(prefix)/lib/tcl$(VERSION)'
++TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+ PRIVATE_INCLUDE_DIR='$(includedir)'
+ HTML_DIR='$(DISTDIR)/html'
+
diff --git a/dev-lang/tcl/files/tcl-8.5.14-conf.patch b/dev-lang/tcl/files/tcl-8.5.14-conf.patch
new file mode 100644
index 000000000000..be303e9f3ef8
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.14-conf.patch
@@ -0,0 +1,11 @@
+--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
++++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
+@@ -1427,7 +1427,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ # get rid of the warnings.
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-8.5.9-gentoo-fbsd.patch b/dev-lang/tcl/files/tcl-8.5.9-gentoo-fbsd.patch
new file mode 100644
index 000000000000..022d81d3e261
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5.9-gentoo-fbsd.patch
@@ -0,0 +1,13 @@
+diff --git a/unix/tcl.m4 b/unix/tcl.m4
+index fdd9d44..31bfca8 100644
+--- a/unix/tcl.m4
++++ b/unix/tcl.m4
+@@ -1601,7 +1601,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ # Version numbers are dot-stripped by system policy.
+ TCL_TRIM_DOTS=`echo ${VERSION} | tr -d .`
+ UNSHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.a'
+- SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so.1'
++ SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so'
+ TCL_LIB_VERSIONS_OK=nodots
+ ;;
+ Darwin-*)
diff --git a/dev-lang/tcl/files/tcl-8.5_alpha6-multilib.patch b/dev-lang/tcl/files/tcl-8.5_alpha6-multilib.patch
new file mode 100644
index 000000000000..ca7535fe0bb5
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5_alpha6-multilib.patch
@@ -0,0 +1,24 @@
+diff -Naur tcl8.5a6.orig/unix/configure tcl8.5a6/unix/configure
+--- tcl8.5a6.orig/unix/configure 2007-04-27 02:33:51.000000000 +0900
++++ tcl8.5a6/unix/configure 2007-05-16 10:27:25.000000000 +0900
+@@ -17623,7 +17623,7 @@
+
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+-TCL_LIBRARY='$(prefix)/lib/tcl$(VERSION)'
++TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+ PRIVATE_INCLUDE_DIR='$(includedir)'
+ HTML_DIR='$(DISTDIR)/html'
+
+diff -Naur tcl8.5a6.orig/unix/configure.in tcl8.5a6/unix/configure.in
+--- tcl8.5a6.orig/unix/configure.in 2007-04-27 02:33:51.000000000 +0900
++++ tcl8.5a6/unix/configure.in 2007-05-16 10:27:25.000000000 +0900
+@@ -645,7 +645,7 @@
+
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+
+-TCL_LIBRARY='$(prefix)/lib/tcl$(VERSION)'
++TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+ PRIVATE_INCLUDE_DIR='$(includedir)'
+ HTML_DIR='$(DISTDIR)/html'
+
diff --git a/dev-lang/tcl/files/tcl-8.5_alpha6-tclm4-soname.patch b/dev-lang/tcl/files/tcl-8.5_alpha6-tclm4-soname.patch
new file mode 100644
index 000000000000..f24cdc6088ee
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.5_alpha6-tclm4-soname.patch
@@ -0,0 +1,11 @@
+--- tcl8.5a6.orig/unix/tcl.m4 2007-04-27 02:33:51.000000000 +0900
++++ tcl8.5a6/unix/tcl.m4 2007-05-16 10:46:31.000000000 +0900
+@@ -1425,7 +1425,7 @@
+ # get rid of the warnings.
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-8.6.1-conf.patch b/dev-lang/tcl/files/tcl-8.6.1-conf.patch
new file mode 100644
index 000000000000..be303e9f3ef8
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.6.1-conf.patch
@@ -0,0 +1,11 @@
+--- tcl8.5.0/unix/tcl.m4.conf 2007-12-20 10:48:05.000000000 +0100
++++ tcl8.5.0/unix/tcl.m4 2007-12-20 10:48:52.000000000 +0100
+@@ -1427,7 +1427,7 @@ dnl AC_CHECK_TOOL(AR, ar)
+ # get rid of the warnings.
+ #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
+
+- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
++ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname,${@}'
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS="-ldl"
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
diff --git a/dev-lang/tcl/files/tcl-configure-LANG.patch b/dev-lang/tcl/files/tcl-configure-LANG.patch
new file mode 100644
index 000000000000..3ef76ef911c0
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-configure-LANG.patch
@@ -0,0 +1,41 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,16 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++# Only set these to C if already set. These must not be set unconditionally
++# because not all systems understand e.g. LANG=C (notably SCO).
++# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
++# Non-C LC_CTYPE values break the ctype check.
++if test "${LANG+set}" = set; then LANG=C; export LANG; fi
++if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
++if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
++if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.