summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/injeqt')
-rw-r--r--dev-libs/injeqt/files/injeqt-1.2.0-gcc7.patch22
-rw-r--r--dev-libs/injeqt/injeqt-1.2.0.ebuild4
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-libs/injeqt/files/injeqt-1.2.0-gcc7.patch b/dev-libs/injeqt/files/injeqt-1.2.0-gcc7.patch
new file mode 100644
index 000000000000..33e51ce739e0
--- /dev/null
+++ b/dev-libs/injeqt/files/injeqt-1.2.0-gcc7.patch
@@ -0,0 +1,22 @@
+From de025e0c472bdb2fcabbc9dc2fd443b91ab28e28 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bart=C5=82omiej=20Burdukiewicz?=
+ <bartlomiej.burdukiewicz@gmail.com>
+Date: Wed, 24 May 2017 18:52:20 +0200
+Subject: [PATCH] fix compilation for GCC 7.1.0
+
+---
+ src/internal/containers.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/internal/containers.h b/src/internal/containers.h
+index 8da4298..78dd212 100644
+--- a/src/internal/containers.h
++++ b/src/internal/containers.h
+@@ -23,6 +23,7 @@
+ #include "internal.h"
+
+ #include <algorithm>
++#include <functional>
+ #include <vector>
+
+ /**
diff --git a/dev-libs/injeqt/injeqt-1.2.0.ebuild b/dev-libs/injeqt/injeqt-1.2.0.ebuild
index 6b98e1bd2372..42e010b49f57 100644
--- a/dev-libs/injeqt/injeqt-1.2.0.ebuild
+++ b/dev-libs/injeqt/injeqt-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
# https://github.com/vogel/injeqt/issues/18
RESTRICT=test
+PATCHES=( "${FILESDIR}/${P}-gcc7.patch" )
+
src_configure() {
local mycmakeargs=(
-DDISABLE_EXAMPLES=ON