summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
deleted file mode 100644
index b89d84c33e6f..000000000000
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit findlib
-
-DESCRIPTION="Library for binding to C libraries using pure OCaml"
-HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
-SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-lang/ocaml-4.02:=
- >=dev-libs/libffi-3.3_rc0:=
- dev-ml/bigarray-compat:=
- dev-ml/integers:=
-"
-DEPEND="${RDEPEND}
- test? ( dev-ml/ounit2 dev-ml/lwt )"
-REQUIRED_USE="ocamlopt"
-
-src_prepare() {
- sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
- default
-}
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- emake -j1 test
-}
-
-src_install() {
- findlib_src_install
- dodoc CHANGES.md README.md
-}