summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.15-r1.ebuild')
-rw-r--r--dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.15-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.15-r1.ebuild b/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.15-r1.ebuild
new file mode 100644
index 000000000000..70f59124a801
--- /dev/null
+++ b/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.15-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit php-pear-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Code Beautifier for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php[tokenizer]"
+RDEPEND="$DEPEND >=dev-php/PEAR-Log-1.8"
+
+pkg_postinst() {
+ if ! has_version dev-lang/php[bzip2] ; then
+ elog "${PN} can optionally use bzip2 features."
+ elog "If you want those, emerge dev-lang/php with this flag in USE."
+ fi
+}