summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild b/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
index 22b44e005afe..a4399f8665cb 100644
--- a/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
@@ -17,14 +17,14 @@ HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv"
+KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
# defaults match what is provided with qtbase by default (except testlib),
# reduces the need to set flags but does increase build time a fair amount
IUSE="
bluetooth +dbus debug designer examples gles2-only +gui help
multimedia +network nfc opengl pdfium positioning +printsupport
- qml quick quick3d serialport sensors spatialaudio speech +sql
- +ssl svg testlib webchannel websockets +widgets +xml
+ qml quick quick3d remoteobjects serialport sensors spatialaudio
+ speech +sql +ssl svg testlib webchannel websockets +widgets +xml
"
# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
REQUIRED_USE="
@@ -37,6 +37,7 @@ REQUIRED_USE="
qml? ( network )
quick3d? ( gui qml )
quick? ( gui qml )
+ remoteobjects? ( network )
spatialaudio? ( multimedia )
sql? ( widgets )
svg? ( gui )
@@ -68,6 +69,7 @@ DEPEND="
qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
quick? ( >=dev-qt/qtdeclarative-${QT_PV}[opengl] )
+ remoteobjects? ( >=dev-qt/qtremoteobjects-${QT_PV} )
sensors? ( >=dev-qt/qtsensors-${QT_PV} )
serialport? ( >=dev-qt/qtserialport-${QT_PV} )
speech? (
@@ -141,7 +143,7 @@ python_configure_all() {
$(pyqt_use_enable quick QtQuick \
$(usev widgets QtQuickWidgets))
$(pyqt_use_enable quick3d QtQuick3D)
- --disable=QtRemoteObjects # not packaged
+ $(pyqt_use_enable remoteobjects QtRemoteObjects)
$(pyqt_use_enable sensors QtSensors)
$(pyqt_use_enable serialport QtSerialPort)
$(pyqt_use_enable spatialaudio QtSpatialAudio)