summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PySocks/PySocks-1.6.7.ebuild')
-rw-r--r--dev-python/PySocks/PySocks-1.6.7.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/PySocks/PySocks-1.6.7.ebuild b/dev-python/PySocks/PySocks-1.6.7.ebuild
new file mode 100644
index 000000000000..6b11651ccc60
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.6.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks http://pypi.python.org/pypi/PySocks"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"