summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild')
-rw-r--r--dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild b/dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild
deleted file mode 100644
index 217fcff06d3e..000000000000
--- a/dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Flexible and efficient upload handling for Flask"
-HOMEPAGE="https://pythonhosted.org/Flask-Testing/
- https://pypi.org/project/Flask-Testing/"
-SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# use the GitHub tarball since the pypi-tarball does not contain the tests
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/flask-0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/${P}-remove-deprecated-module.patch" )
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}