summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h11')
-rw-r--r--dev-python/h11/Manifest1
-rw-r--r--dev-python/h11/h11-0.9.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/h11/Manifest b/dev-python/h11/Manifest
index 12e594273e5d..8725687167ee 100644
--- a/dev-python/h11/Manifest
+++ b/dev-python/h11/Manifest
@@ -1 +1,2 @@
DIST h11-0.8.1.tar.gz 94009 BLAKE2B 34c43874ba8d1e59f89d9d71a5eb8033583aefc6659f6cf645067267a68769f01864b997623ad175e263d4918e2e572e2af49f4ddf743608fc259ab7b4a51022 SHA512 3310dcd8552de4440ed9669fd37b3fc4d76073a9801decb705bceee3c1e98ff83470bd124ecf36e1ec3457ff2fb4da6f4fbf077daa810c28ab73044dfab709d4
+DIST h11-0.9.0.tar.gz 93331 BLAKE2B 46bc596f110d78ad162daaec68b9fa1e3a5ec828b45d66b6067bbdf27a5e81f110a7c1e1d394a4a11d797b9a6ba69d7c9fb182edbf753c5ea1a66f2cd8c01ed7 SHA512 fb323ebf0cc95d89bb7e73cf1f393d2588961ed6dd95630ad692e36f15141ae1de7a0bfe3ef2855f0e9b7c8cf2abba5cf808547bb4bb4d10ebb525122ac63d4a
diff --git a/dev-python/h11/h11-0.9.0.ebuild b/dev-python/h11/h11-0.9.0.ebuild
new file mode 100644
index 000000000000..42d541a4f8ba
--- /dev/null
+++ b/dev-python/h11/h11-0.9.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of HTTP/1.1 inspired by hyper-h2"
+HOMEPAGE="https://github.com/python-hyper/h11 https://pypi.python.org/pypi/h11"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest