summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest7
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.19.3.ebuild (renamed from dev-python/inline-snapshot/inline-snapshot-0.18.2.ebuild)7
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.20.0.ebuild (renamed from dev-python/inline-snapshot/inline-snapshot-0.19.0.ebuild)2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.20.1.ebuild (renamed from dev-python/inline-snapshot/inline-snapshot-0.19.1.ebuild)2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.20.2.ebuild63
5 files changed, 73 insertions, 8 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index 35df039a23da..fc92c7d015f5 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1,3 +1,4 @@
-DIST inline_snapshot-0.18.2.tar.gz 225777 BLAKE2B 45a08224c8ec94e052c6fe1393ad9b12c7227b9208ef591f323b15baf1622866fcfc7c91167fa8d352dae895e140348df4b3e492c52e441c2b8799e7f53f7ca5 SHA512 6b370ee0a717834f361b712ee71434362a44e92688df298572a801bbf384d69bd37816b2aa1e701f77d72149fff2ec5da9fceb24980af15de807973451e161c9
-DIST inline_snapshot-0.19.0.tar.gz 87554 BLAKE2B 9cb8d15b1d33844053b0ed5df8a4d47ea290bf3c67872671e147fb284e1fb2013bffda21fb38e96c01336b768a1315b81ba8a71d9df8a716ee4ffd92658160a8 SHA512 bb528a6657196938994e678042e379159d28635cc7679ab21a42e550efb35e1edc58fd58ec0b25560866062c6956b8d73f475a682c43255ff18ce31ed55cf9fd
-DIST inline_snapshot-0.19.1.tar.gz 88072 BLAKE2B 83ddb98a9ff7fe6b4a5071cd9452b81ee92b0f2538c0b55876bc4e4a08770a64415c95334ce4cb825000e1bd295fa582eb3be6db400e75447fe85daed360c17e SHA512 3750de436a5b19002728df954d4b60e30f7fd6ff0ae49e1a0268cf61d5ba40b809ccaf2b8474b9c3a2b9195a9b0edb7ec98dc4d29af77738fab997e566890bd5
+DIST inline_snapshot-0.19.3.tar.gz 88636 BLAKE2B 537e68eec4f7db9ddeb8cea1e93f872160129d8b7b51b3d693c0cebb94c2cf5652d57989ccb44b7a3f3157ffbe6322c032fce42594d94f8daf454f922accad0b SHA512 b1f3a0123a1f17ffb85cb296861e3558057d45a8a576d72b2dca1ad1ce3151d4354b6bf86f9e0fb21d941d7ee708fd33c3961fdd1c0bad4c7368b720388fcf85
+DIST inline_snapshot-0.20.0.tar.gz 89597 BLAKE2B 264020c3e3413e6e687d0ffb8c1659778782e065ef1fe7b4dc058fc547ddbba29302b653005543b6200a0bea948ae9d3eec5a981899aba65c1cba083fc41eea3 SHA512 d06243899c4a391bc27965d30db307fb14249797e83710773c392514fe82c8d199cd09a75d0b86374b59def2b9000bf636e27a15b76df0355fd464498f08f9ef
+DIST inline_snapshot-0.20.1.tar.gz 89634 BLAKE2B 2fc5633bee452f6eb69ad604a5dc4ada30916d698eeb44e4928490d6f56346c8cb6f43341ddb425cdc725216ba949610e133d977e32b3ac82a5a289b851826b3 SHA512 41df474a0f4a0e93d20a6729e5c8a93bd36b796f42a10c087144f816641df3680c905ca5b72aac923a7db782730e111a85b0594987b00470dc5cf33cfd8305fe
+DIST inline_snapshot-0.20.2.tar.gz 91060 BLAKE2B dc5dd87a809727f48a2bb376ffb602517c2acfad8ce8738d443f2dcf863b268b9ef1408771bdbfee6ccbb6d25ea3e8afdf2d690df021de196f30514a57ea0fb2 SHA512 e749efea54bdca1f399aa81335e65ab0e48887de6d4a9aa9905086886bdd44ef31eaf95c75edd5ee1e6ee011e31c450fb077d09f49415653e5c8e19a3ad4a944
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.18.2.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.19.3.ebuild
index eefc08e9c6dc..06a0d4f6b391 100644
--- a/dev-python/inline-snapshot/inline-snapshot-0.18.2.ebuild
+++ b/dev-python/inline-snapshot/inline-snapshot-0.19.3.ebuild
@@ -21,11 +21,8 @@ KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
- >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
- >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
>=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
>=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
' 3.10)
@@ -33,6 +30,8 @@ RDEPEND="
BDEPEND="
test? (
dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
>=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
>=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
@@ -52,6 +51,8 @@ python_test() {
local EPYTEST_DESELECT=(
# requires pyright
'tests/test_typing.py::test_typing[pyright]'
+ # TODO
+ tests/test_formating.py::test_format_command_fail
)
local -x COLUMNS=80
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.19.0.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.20.0.ebuild
index fd8a5cc819a8..114c3b78ab60 100644
--- a/dev-python/inline-snapshot/inline-snapshot-0.19.0.ebuild
+++ b/dev-python/inline-snapshot/inline-snapshot-0.20.0.ebuild
@@ -21,7 +21,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND="
>=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
- >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.2.0[${PYTHON_USEDEP}]
>=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.19.1.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.20.1.ebuild
index fd8a5cc819a8..114c3b78ab60 100644
--- a/dev-python/inline-snapshot/inline-snapshot-0.19.1.ebuild
+++ b/dev-python/inline-snapshot/inline-snapshot-0.20.1.ebuild
@@ -21,7 +21,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND="
>=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
- >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.2.0[${PYTHON_USEDEP}]
>=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.20.2.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.20.2.ebuild
new file mode 100644
index 000000000000..114c3b78ab60
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.20.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezer-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ # TODO
+ tests/test_formating.py::test_format_command_fail
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,pytest_freezer,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest -p pytest_mock
+}