summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inotifyx')
-rw-r--r--dev-python/inotifyx/Manifest2
-rw-r--r--dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild28
-rw-r--r--dev-python/inotifyx/inotifyx-0.2.2.ebuild28
-rw-r--r--dev-python/inotifyx/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/inotifyx/Manifest b/dev-python/inotifyx/Manifest
new file mode 100644
index 000000000000..7d380a2957cc
--- /dev/null
+++ b/dev-python/inotifyx/Manifest
@@ -0,0 +1,2 @@
+DIST inotifyx-0.2.0.tar.gz 11302 SHA256 1a1769816324a1ccb766ecd7f336cf07b8bc498477d83cbb0e6dcea69c1dd60b SHA512 6b1230d16c47bd77256259a40051ab48963fe9de96f0242fc0e34d467ae012708d9b43e149ef29acc43cefe8dc02cc7fdbe11572ea4515a9c3456c73a6d27723 WHIRLPOOL f293ed382a540ef43b44c3a09992a39d31f9f7f086be1ee04a3f570519116ca44a9c4cc2789a42d092f32f9b3967958d108b3bb4d80858adc7d686d1ec8072e1
+DIST inotifyx-0.2.2.tar.gz 11831 SHA256 bad6a84df2a110f282d398dff112b1d3c838a6d50907305121a9af590d185fab SHA512 a00a947da2bd31d9b867f21666aceed48b0bf9be6b1b3643676450ed68bd71400601e57e004bcd45e93274cabf933694887797f3a4e334ce6924236763112c56 WHIRLPOOL 806c83a69141d901f3df443739bc3a5dfc6d5f66dc45fc4c8c6780e1267aa709f0c3bbdb775caa332bdcd954b262523fcd3b8bf2867e408382175f806925dfeb
diff --git a/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild b/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..e57c28f4453e
--- /dev/null
+++ b/dev-python/inotifyx/inotifyx-0.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Linux inotify file system event monitoring API"
+HOMEPAGE="http://www.alittletooquiet.net/software/inotifyx/"
+SRC_URI="http://launchpad.net/inotifyx/dev/v${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=1
+}
+
+python_test() {
+ "${PYTHON}" setup.py build -b "build-${EPYTHON}" test || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/inotifyx/inotifyx-0.2.2.ebuild b/dev-python/inotifyx/inotifyx-0.2.2.ebuild
new file mode 100644
index 000000000000..e57c28f4453e
--- /dev/null
+++ b/dev-python/inotifyx/inotifyx-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Linux inotify file system event monitoring API"
+HOMEPAGE="http://www.alittletooquiet.net/software/inotifyx/"
+SRC_URI="http://launchpad.net/inotifyx/dev/v${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=1
+}
+
+python_test() {
+ "${PYTHON}" setup.py build -b "build-${EPYTHON}" test || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/inotifyx/metadata.xml b/dev-python/inotifyx/metadata.xml
new file mode 100644
index 000000000000..fe3c88bfac68
--- /dev/null
+++ b/dev-python/inotifyx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">inotifyx</remote-id>
+ </upstream>
+</pkgmetadata>