summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lark/lark-1.1.9.ebuild')
-rw-r--r--dev-python/lark/lark-1.1.9.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/lark/lark-1.1.9.ebuild b/dev-python/lark/lark-1.1.9.ebuild
deleted file mode 100644
index 6cccd93b1cec..000000000000
--- a/dev-python/lark/lark-1.1.9.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
-HOMEPAGE="
- https://github.com/lark-parser/lark/
- https://pypi.org/project/lark/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-# dev-python/regex doesn't support pypy
-BDEPEND="
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/regex[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # require dev-python/js2py which is a really bad quality package
- tests/test_nearley/test_nearley.py
- )
-
- epytest
-}