summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.950.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 4437c142098e..c43416443d74 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -5,3 +5,4 @@ DIST mypy-0.931.tar.gz 2779826 BLAKE2B 11986102c6bc498a23bae52002e6ac515fa03724e
DIST mypy-0.940.tar.gz 2700469 BLAKE2B 4ac13002c3752566ade30a720c4de56d600552221c42f930af54a68573e6b5eb10de90ce66e2cd42f9eb419d5d09e354e4bf2d09cbcf0d6b841ab0e6710d7058 SHA512 5131ea3fe8d96f12442c68dddf04261582a063dcdd031804276263949af9f9af967be3dd775868d289709987773e1911f33e1f43951389f93cabf91c771e271f
DIST mypy-0.941.tar.gz 2700297 BLAKE2B 1d0369336b82c167dc25da8bcc21817b351a65a2543727f08c2e14aa15a75fec21b0937eb09b8060b405c09703b8052d4ed2df65d6e27f5dd429998b110a9e35 SHA512 39ef6e0d9215f0f530ca572d3b701a877f9b968034c2ca5a04549bf6a337a8d3609c23bc45bf45b16209128d26ab2b74bca27ecbdc5de53581429b47fb348aa8
DIST mypy-0.942.tar.gz 2701940 BLAKE2B 5501466e57b4afb8825e6c804cbdc270c79ff457c39f2e5834f4b68df70263c05b2b9abb08fe58202ee65f5e22d2291f39fcb1fc47168416134538c5f6e12ab3 SHA512 79b83587eefad10d7d20d3bfd8484a9e8b2d363e68c1e5ffaa3a82ca8b8f8d9183036ea46695a634f9156911d6f918af684ac636105b37b3a5d0e958f5d661f4
+DIST mypy-0.950.tar.gz 2746164 BLAKE2B 8466012fd3622f5e730acef774115ac84ff8c6f5488213a450de63d5acc790f937b7c69a1b05b46deef6fe8f81a13ed8e85f83c6c22cce9abdbb73b2ecf4179c SHA512 949d1dade3f225bbef0934fff040f7d5aec47039f554a669ca491d6cb46d56de3fcae0186864cdcaf5dec1347bc3af453218520536a0afa77e89a5c0e4640500
diff --git a/dev-python/mypy/mypy-0.950.ebuild b/dev-python/mypy/mypy-0.950.ebuild
new file mode 100644
index 000000000000..7a153fc2a262
--- /dev/null
+++ b/dev-python/mypy/mypy-0.950.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}