summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pcapy')
-rw-r--r--dev-python/pcapy/Manifest1
-rw-r--r--dev-python/pcapy/pcapy-0.11.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pcapy/Manifest b/dev-python/pcapy/Manifest
index 2a4bacc73eb1..e829b9bddd79 100644
--- a/dev-python/pcapy/Manifest
+++ b/dev-python/pcapy/Manifest
@@ -1 +1,2 @@
DIST pcapy-0.11.1.tar.gz 31439 BLAKE2B c41a9ead869aea65470ff5db368f9eb8a813ac5aec4cde23e2375d1d9d5f9d9885d2ae88a147eb21820e3c1875ffa490a1476b346bd0eaf5082bab9e239bfb16 SHA512 60eebbeae84da33d7bd2eb2398687007a305e8986fcc183d8061fa50bbc0cdf9a66c17461a32a652ca39952dd0935b164bd98a200f82ffef00ffaa55409522a3
+DIST pcapy-0.11.2.tar.gz 32040 BLAKE2B 467d35dff94d2f32e66f9caae88bb43218f3391745230347c39e1db241543e4e9431cfe49185151025201d0913ca102d1f9567f4cf70a83d6fbbade76ec35ecf SHA512 353a2240a9b8541f30f9df472b6977664f94966fbda327aa72f73f26257086caf1db13d55c57859abf2237f5867c11b6ab582742e04d5c16184ea42dc547301c
diff --git a/dev-python/pcapy/pcapy-0.11.2.ebuild b/dev-python/pcapy/pcapy-0.11.2.ebuild
new file mode 100644
index 000000000000..78a8a1c5989d
--- /dev/null
+++ b/dev-python/pcapy/pcapy-0.11.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python pcap extension"
+HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
+SRC_URI="https://github.com/CoreSecurity/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${DEPEND}
+net-libs/libpcap"
+
+python_test() {
+ cd "${S}/tests" || die "Unable to activate test suite"
+ "${EPYTHON}" pcapytests.py || die "Tests failed with ${EPYTHON}"
+}