summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest1
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.10.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index c76ed9c9a6af..ece613d8897c 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,2 +1 @@
-DIST pygraphviz-1.10.zip 120582 BLAKE2B 965b84ec6951c364084ddde4f0594ad7c14eb7e884062ad4f24042b6298b9caf10b3aa33eecfe8154c87c4bfd8d3651acc586129b019aef8b809130d69c03f82 SHA512 571c35f7a8013d5f128fcfbbd68372c8660560847afa0648737eae6d305a9283b69dce23a1b1aeb808bd4eac9c9cefa72b1d358fbc47b724a0b70997ea3f6d84
DIST pygraphviz-1.11.zip 120803 BLAKE2B 004312750bcb9fab5c39af2c1de6c452489d9a2deea8211e6bb7cd722e9043070644b61c78047b01d649d41194441d82ffe2dde9fb17b6d9233bd0acee539c7e SHA512 3914d29fb214e1f7d59c7849e1e63e783902acd262912eccffbf6a67f8cbf6f540b9f2e84c9e7b4f0d90fae27f451a701a3b75a4dcb15b8a81bed463b34e2ef2
diff --git a/dev-python/pygraphviz/pygraphviz-1.10.ebuild b/dev-python/pygraphviz/pygraphviz-1.10.ebuild
deleted file mode 100644
index 6c27d3248696..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.10.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="
- https://pygraphviz.github.io/
- https://github.com/pygraphviz/pygraphviz/
- https://pypi.org/project/pygraphviz/
-"
-SRC_URI="$(pypi_sdist_url "${PN}" "${PV}" .zip)"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 ~riscv x86 ~x86-linux ~ppc-macos ~x64-macos"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-DEPEND="
- media-gfx/graphviz
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- app-arch/unzip
- dev-lang/swig:0
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- swig -python pygraphviz/graphviz.i || die
-}
-
-python_test() {
- cd "${BUILD_DIR}"/install || die
- epytest
-}
-
-python_install_all() {
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
-
- distutils-r1_python_install_all
-}