summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypax/pypax-0.9.0.ebuild')
-rw-r--r--dev-python/pypax/pypax-0.9.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pypax/pypax-0.9.0.ebuild b/dev-python/pypax/pypax-0.9.0.ebuild
deleted file mode 100644
index a1713f446e00..000000000000
--- a/dev-python/pypax/pypax-0.9.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
-HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
- https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
-SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
-
-S="${WORKDIR}/elfix-${PV}/scripts"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="+ptpax +xtpax"
-
-REQUIRED_USE="|| ( ptpax xtpax )"
-
-RDEPEND="
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-src_compile() {
- unset PTPAX
- unset XTPAX
- use ptpax && export PTPAX="yes"
- use xtpax && export XTPAX="yes"
- distutils-r1_src_compile
-}