summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild')
-rw-r--r--dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild b/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild
deleted file mode 100644
index f178708bfd6b..000000000000
--- a/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A plugin to fake subprocess for pytest"
-HOMEPAGE="
- https://github.com/aklajnert/pytest-subprocess/
- https://pypi.org/project/pytest-subprocess/
-"
-SRC_URI="
- https://github.com/aklajnert/pytest-subprocess/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/anyio[${PYTHON_USEDEP}]
- >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.15.1[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # https://github.com/aklajnert/pytest-subprocess/pull/162
- sed -i -e '/py_modules/d' -e '/find_packages/d' setup.py || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_subprocess.fixtures,pytest_asyncio.plugin
- epytest -p rerunfailures
-}