summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyyaml/pyyaml-6.0.2.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-6.0.2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/pyyaml/pyyaml-6.0.2.ebuild b/dev-python/pyyaml/pyyaml-6.0.2.ebuild
index 9be8de2241fe..fcccf03e2834 100644
--- a/dev-python/pyyaml/pyyaml-6.0.2.ebuild
+++ b/dev-python/pyyaml/pyyaml-6.0.2.ebuild
@@ -24,7 +24,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="examples"
DEPEND="
@@ -38,6 +38,8 @@ BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
+distutils_enable_tests pytest
+
src_configure() {
export PYYAML_FORCE_CYTHON=1
}
@@ -47,11 +49,7 @@ python_test() {
local -x PYTHONPATH="tests/legacy_tests:${PYTHONPATH}"
# upstream indicates testing may pollute the package
cp -a "${BUILD_DIR}"/{install,test} || die
- "${BUILD_DIR}"/test/usr/bin/python <<-EOF || die "Tests failed on ${EPYTHON}"
- import sys
- import test_all
- sys.exit(0 if test_all.main() else 1)
- EOF
+ epytest
}
python_install_all() {