summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shortuuid/shortuuid-0.4.3.ebuild')
-rw-r--r--dev-python/shortuuid/shortuuid-0.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/shortuuid/shortuuid-0.4.3.ebuild b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
new file mode 100644
index 000000000000..a746f39b1894
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs"
+HOMEPAGE="https://pypi.python.org/pypi/shortuuid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} ${PN}/tests.py || die "Tests failed with ${EPYTHON}"
+} \ No newline at end of file