summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/files/tikzplotlib-0.10.1-matplotlib-3.6.0.patch48
-rw-r--r--dev-python/tikzplotlib/metadata.xml14
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.10.1-r1.ebuild52
4 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
deleted file mode 100644
index a43373fd4058..000000000000
--- a/dev-python/tikzplotlib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST tikzplotlib-0.10.1.gh.tar.gz 98265 BLAKE2B 7664e702afb38580af78f2b0887000215a5a0c2ef57e4f9ca5d1100bcba257365b89aee805e800e3a9b5a992487c1ee9733088dadc53941405c0055336478130 SHA512 13a750d9929db1d4ce4608a296523be55878c702846b0b339c6c002cbdf4e8f7b1ffea84db612d8932a379fafce9b4fe6ab6ce4325bf780f211cc0b885a15818
diff --git a/dev-python/tikzplotlib/files/tikzplotlib-0.10.1-matplotlib-3.6.0.patch b/dev-python/tikzplotlib/files/tikzplotlib-0.10.1-matplotlib-3.6.0.patch
deleted file mode 100644
index 2c3a0e506cc6..000000000000
--- a/dev-python/tikzplotlib/files/tikzplotlib-0.10.1-matplotlib-3.6.0.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-https://github.com/texworld/tikzplotlib/issues/567
-https://github.com/texworld/tikzplotlib/pull/558
-
-From f9988eb6aa7cc7d55c0bb528c53e7a8408308939 Mon Sep 17 00:00:00 2001
-From: Paul Kim <44695374+thekpaul@users.noreply.github.com>
-Date: Mon, 3 Oct 2022 01:15:21 +0900
-Subject: [PATCH 1/2] Legend Compatibility Issue in texworld#557
-
-.
-
-.
---- a/src/tikzplotlib/_legend.py
-+++ b/src/tikzplotlib/_legend.py
-@@ -78,7 +78,7 @@ def draw_legend(data, obj):
- if alignment:
- data["current axes"].axis_options.append(f"legend cell align={{{alignment}}}")
-
-- if obj._ncol != 1:
-+ if obj._ncols != 1:
- data["current axes"].axis_options.append(f"legend columns={obj._ncol}")
-
- # Write styles to data
-
-From 61f7ea2fb2633f1c0de48f8da1f90a5f9ba078c1 Mon Sep 17 00:00:00 2001
-From: Paul Kim <44695374+thekpaul@users.noreply.github.com>
-Date: Wed, 5 Oct 2022 11:30:48 +0900
-Subject: [PATCH 2/2] Backwards Compat for `ncol`
-
-Co-authored-by: st-- <st--@users.noreply.github.com>
---- a/src/tikzplotlib/_legend.py
-+++ b/src/tikzplotlib/_legend.py
-@@ -78,8 +78,13 @@ def draw_legend(data, obj):
- if alignment:
- data["current axes"].axis_options.append(f"legend cell align={{{alignment}}}")
-
-- if obj._ncols != 1:
-- data["current axes"].axis_options.append(f"legend columns={obj._ncol}")
-+ try:
-+ ncols = obj._ncols
-+ except AttributeError:
-+ # backwards-compatibility with matplotlib < 3.6.0
-+ ncols = obj._ncol
-+ if ncols != 1:
-+ data["current axes"].axis_options.append(f"legend columns={ncols}")
-
- # Write styles to data
- if legend_style:
-
diff --git a/dev-python/tikzplotlib/metadata.xml b/dev-python/tikzplotlib/metadata.xml
deleted file mode 100644
index c432fbaf0427..000000000000
--- a/dev-python/tikzplotlib/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>tikzplotlib is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of tikzplotlib is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of tikzplotlib retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
- <upstream>
- <remote-id type="github">texworld/tikzplotlib</remote-id>
- <remote-id type="pypi">tikzplotlib</remote-id>
- </upstream>
- <stabilize-allarches/>
-</pkgmetadata>
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.10.1-r1.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.10.1-r1.ebuild
deleted file mode 100644
index 7b21d67ed209..000000000000
--- a/dev-python/tikzplotlib/tikzplotlib-0.10.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="
- https://github.com/texworld/tikzplotlib/
- https://pypi.org/project/tikzplotlib/
-"
-SRC_URI="https://github.com/texworld/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# https://github.com/texworld/tikzplotlib/issues/567 for mpl-3.6.0 dep
-RDEPEND="
- app-text/texlive[extra]
- <dev-python/matplotlib-3.6.0[latex,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/webcolors[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest-codeblocks[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.10.1-matplotlib-3.6.0.patch
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/mock
-
-src_test() {
- local -x MPLBACKEND=Agg
- virtx distutils-r1_src_test
-}
-
-python_test() {
- epytest || die "Tests failed with ${EPYTHON}"
-}