summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/files/gcc6.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild3
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-9999.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/dev-ros/image_cb_detector/files/gcc6.patch b/dev-ros/image_cb_detector/files/gcc6.patch
new file mode 100644
index 000000000000..af68c1e654ca
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: image_cb_detector/CMakeLists.txt
+===================================================================
+--- image_cb_detector.orig/CMakeLists.txt
++++ image_cb_detector/CMakeLists.txt
+@@ -24,7 +24,7 @@ catkin_package(INCLUDE_DIRS include
+
+ # define some includes
+ include_directories(include)
+-include_directories(SYSTEM ${Boost_INCLUDE_DIRS}
++include_directories(${Boost_INCLUDE_DIRS}
+ ${catkin_INCLUDE_DIRS}
+ ${OpenCV_INCLUDE_DIRS}
+ )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 54172203fc68..972abdce8d2f 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,3 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
index 54172203fc68..972abdce8d2f 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,3 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )