summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild
new file mode 100644
index 000000000000..bfe2d620c882
--- /dev/null
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile
+
+DESCRIPTION="Guile bindings of libgcrypt"
+HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://notabug.org/cwebber/${PN}.git"
+else
+ SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+RDEPEND="
+ ${GUILE_DEPS}
+ dev-libs/libgcrypt:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ guile_src_prepare
+ eautoreconf
+}