summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/hyprland-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/gui-wm/hyprland/hyprland-9999.ebuild b/gui-wm/hyprland/hyprland-9999.ebuild
index 0201229de28e..f7713480f505 100644
--- a/gui-wm/hyprland/hyprland-9999.ebuild
+++ b/gui-wm/hyprland/hyprland-9999.ebuild
@@ -48,19 +48,20 @@ RDEPEND="
x11-libs/pixman
X? (
x11-libs/libxcb:0=
+ x11-base/xwayland
+ x11-libs/xcb-util-errors
+ x11-libs/xcb-util-wm
)
"
DEPEND="
${RDEPEND}
- ${WLROOTS_DEPEND}
>=dev-libs/hyprland-protocols-0.3
>=dev-libs/hyprlang-0.3.2
>=dev-libs/wayland-protocols-1.36
>=gui-libs/hyprutils-0.2.1
"
BDEPEND="
- ${WLROOTS_BDEPEND}
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
app-misc/jq
dev-build/cmake
>=dev-util/hyprwayland-scanner-0.3.8
@@ -70,12 +71,12 @@ BDEPEND="
pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
- if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
- eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ if tc-is-gcc && ver_test $(gcc-version) -lt 14 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-14 to build"
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Hyprland!"
- elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
+ eerror "Hyprland requires >=sys-devel/clang-18 to build"
eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
die "Clang version is too old to compile Hyprland!"
fi
@@ -86,8 +87,6 @@ src_configure() {
$(meson_feature legacy-renderer legacy_renderer)
$(meson_feature systemd)
$(meson_feature X xwayland)
- -Dwlroots:backends=drm,libinput$(usev X ',x11')
- -Dwlroots:xcb-errors=disabled
)
meson_src_configure