summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.4.1.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.4.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.4.1.ebuild b/media-libs/gmmlib/gmmlib-22.4.1.ebuild
deleted file mode 100644
index 0a7ae2c25cdb..000000000000
--- a/media-libs/gmmlib/gmmlib-22.4.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
- if [[ ${PV%9999} != "" ]] ; then
- : ${EGIT_BRANCH:="release/${PV%.9999}"}
- fi
- inherit git-r3
-else
- KEYWORDS="amd64"
- SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
- S="${WORKDIR}/${PN}-intel-${P}"
-fi
-
-DESCRIPTION="Intel Graphics Memory Management Library"
-HOMEPAGE="https://github.com/intel/gmmlib"
-
-LICENSE="MIT"
-SLOT="0/12.3"
-IUSE="+custom-cflags test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
- "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
- "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING="$(usex test)"
- -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
- )
-
- cmake_src_configure
-}