summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.20.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index 58f2887f5865..1accd226dc1d 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,2 +1,3 @@
DIST gst-rtsp-server-1.16.3.tar.xz 699472 BLAKE2B 8937ce9d0550b11657496dec5a79c00f74de4da9deb9236693a25f4e266a779c8d4f439b127c2af87c874327e10f01f6a1d74fc1cd1bd0eca20093341568cb82 SHA512 f9ca08cfef92b74a63279a5480cfc1b18557f3062aadc765dd4d3de57d62b9ddf3ca98a4680dcd0f050812128c5c03592cdbf9d8329b85a6c2f3a39209c07701
DIST gst-rtsp-server-1.20.2.tar.xz 360388 BLAKE2B 6593a83e8746001c26abe623608390448f8cbe6710e3215eeea483940a2fb544617ac159a2e03ba3c84918d8132fbad1a91d638491a226dd13e83f87a3219d7d SHA512 fac3338603f1e31cb1da3c163784fbed1663e0cee722b47c3a6bb369296e5fbff3fdc9925952fe387d51f05ffaeef2a7400369a7006b805f3cb8b454566642bd
+DIST gst-rtsp-server-1.20.3.tar.xz 362348 BLAKE2B 45d5ff58d76b9b83baa6e5956976e1fdc10dae3200d30a877a26ddafda4f919ecaeca85fceec6fb3b7802303d152087d3f5813f6e3bf36a941a0c46fceeb1292 SHA512 15baf83d77d57d1e2517feffad68b4508e7a959863b5e6fa3d0f564c81786df8d3c1e57d8b8a9f9b623e19212feb137dfe89d8e385f518c86f205c4461802007
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.3.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.3.ebuild
new file mode 100644
index 000000000000..b48154a12921
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc "${S}"/examples/*.c
+ fi
+}